Go Back   Tech Support Forum > Networking Forum > Security and Firewalls

[SOLVED] Network printers printing garbage - Bugbear virus ?

This is a discussion on [SOLVED] Network printers printing garbage - Bugbear virus ? within the Security and Firewalls forums, part of the Tech Support Forum category. We have 50 computers in a LAN with Eset anti-virus. We also have 5 big network printers (Xerox, Olivetti, HP).


Closed Thread
 
Thread Tools Search this Thread
Old 02-05-2010, 06:07 AM   #1
Registered Member
 
Join Date: Feb 2010
Posts: 2
OS: Win XP



We have 50 computers in a LAN with Eset anti-virus. We also have 5 big network printers (Xerox, Olivetti, HP). Two weeks ago the one Olivetti printer starting printing just one line of junk on each page until all the trays were empty of paper. The HP started printing one blank page for each page printed. The Xerox printers were not effected. From the Internet search it appears that the network was infected with the Bugbear-B virus which effects the network printers - it corrupts the drivers and make them print one line of gibberish until the paper is finished.

I scanned the computers with Eset and didn't pick up any virus. Then I downloaded different Bugbear removal tools (e.g. Norton, Mcafee, Stinger) but not one of them could find any virus. I then checked the Windows start commands and found one computer with a weird startup program - as described for the Bugbear virus. The first line on the first page that gets printed reads: This program cannot be run in Dos Mode (Bugbear). I deleted this program. Then I disconnected the computer and scanned it in Safe Mode with System Restore disabled but couldn't pick up any virus. I then scanned some of the other computers the same way, also with MalwareBytes as well as other anti-virus/Malware programs like Stinger but could not find any virus anywhere.

I reinstalled WinXP from scratch (reformatted hdd) on the computer that had the virus. In the meantime the Olivetti printer was still pumping out pages very randomly. I tried to see which computer caused the printer to start printing like this but could not really identify it. These are laser printers and you never get to see what is in the print queue. If I would also remove the paper tray and go from computer to computer and sometimes one computer's print queue will show that it is out of paper, other times it will show this for a number of computers. I actually reinstalled WinXP on about 6 computers and it didn't help. I also reinstalled the printer drivers - after deleting the printers from Windows Printers and deleting the specific drivers from Windows. This helped for about 7 hours - and then the problem started again. I also checked for infected flashdrives or CD's and removed a few. It is only the HP and the one Olivetti printer that is effected. The Olivetti printer guys say that is because of the type of driver software. The Xerox printers have very complicated software drivers which don't get affected. I have reinstalled printer drivers 3 times now but every time the problem starts again - within 3-4 hours. The other weird thing is that it only happens when two or more people are sending stuff to the printer to be printed at the same time. When I organise the users into 5 minute time slots for printing (one at a time), the problem doesn't occur.

I phoned some of the anti-virus companies but nobody has been able to help me so far. What they do say is that an infected printer driver cannot infect other printers. It still seems that somewhere there is an infected computer but the anti-virus packages can't find it and therefore I don't know which one is infected (if that is the case). We also have two servers and both were checked and were clean. What is also peculiar is that I wasn't able to find the virus startup program in the Windows startup commands on any other computer - checked all 50.

I am desperate please.

Thanks
Kobus

__________________
Koekemoer is offline  
Old 02-05-2010, 08:10 PM   #2
2xg
Team Manager, Networking Forums, Microsoft MVP
 
2xg's Avatar

Microsoft Most Valuable Professional
 
Join Date: Aug 2009
Location: SoCal
Posts: 20,021
OS: Windows O/S'es



Hello and welcome to TSF,

The printer itself cannot be infected by a Virus, never heard if this. It might have struck the computer's hard drive and when you try to send a print job to the printer, it was the printer driver that got affected and not the printer itself.

Aside from Windows Updates, I would suggest a really good corporate Security Suite like McAfee's Total Protection Service or TOPS for your Server and Client computers as well, it's very reasonable =>http://www.mcafee.com/us/medium/index.html

__________________

Microsoft MVP 2011-2013 Windows Expert Consumer
Networking Articles & Tutorials
2xg is offline  
Old 02-08-2010, 01:10 AM   #3
Registered Member
 
Join Date: Feb 2010
Posts: 2
OS: Win XP



Hi Guys
Thanks for the help. The problem has been solved. Disconnected all 50 computers, booted in Safe Mode, ran Malwarebytes to clean them up and rebooted.

The solution was to disconnect all of them and only connect them up only once they have been cleaned.

Thanks again.
Kobus
__________________
Koekemoer is offline  
Old 02-08-2010, 09:39 AM   #4
2xg
Team Manager, Networking Forums, Microsoft MVP
 
2xg's Avatar

Microsoft Most Valuable Professional
 
Join Date: Aug 2009
Location: SoCal
Posts: 20,021
OS: Windows O/S'es



You're welcome! Glad your issue has been resolved.
__________________

Microsoft MVP 2011-2013 Windows Expert Consumer
Networking Articles & Tutorials
2xg is offline  
Old 02-02-2011, 06:20 PM   #5
Registered Member
 
Join Date: Feb 2011
Posts: 1
OS: XP



I’m having the exact same issue you had. Was it the bugbear or what virus was it?
__________________
PEREZ1025 is offline  
Old 02-02-2011, 06:32 PM   #6
2xg
Team Manager, Networking Forums, Microsoft MVP
 
2xg's Avatar

Microsoft Most Valuable Professional
 
Join Date: Aug 2009
Location: SoCal
Posts: 20,021
OS: Windows O/S'es



PEREZ1025 - If you need assistance please create your own thread and we'll help you.
Quote:
Originally Posted by PEREZ1025 View Post
I’m having the exact same issue you had. Was it the bugbear or what virus was it?

__________________

Microsoft MVP 2011-2013 Windows Expert Consumer
Networking Articles & Tutorials
2xg is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 02:31 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts