Go Back   Tech Support Forum > Networking Forum > File and Application Sharing

Windows 7 laptop sharing non public folders

This is a discussion on Windows 7 laptop sharing non public folders within the File and Application Sharing forums, part of the Tech Support Forum category. Ok guys, just like the title says, I have several laptops on my home network. The oldest is an HP


Reply
 
Thread Tools Search this Thread
Old 05-25-2010, 03:45 PM   #1
Registered Member
 
Join Date: Mar 2010
Location: Costa Rica
Posts: 63
OS: Windows 7 Ultimate 64 bit



Ok guys, just like the title says, I have several laptops on my home network.

The oldest is an HP running Windows XP Home, a second one that is an Acer that's running Windows Vista and the newest is a Toshiba running Windows 7 Ultimate 64bit.

Now, I don't have any problems with sharing files, it's rather the other way around, the XP laptop and Vista laptop have access to ALL my files, not just what's in the Public folder without having to use a password or anything. But the Toshiba with Windows 7 laptop only has access to the Public shared folders on the XP and Vista laptops.

I have sharing setup so that I have to access my user account on the Vista laptop with my user password to get to the shared folders on that laptop. I don't have to do anything to get to the shared folders on the XP laptop, but if there were a way, I would like to have to use a password to get to them. I have a password set on our wireless network, and I have named the workgroup the same on all the laptops, but from time to time friends and family are over and so I don't know if they have access to the folders on the XP laptop or the Toshiba just by being connected to the network even if they aren't members of the same workgroup.

So, any advice is appreciated guys. Thanks ahead of time.

__________________
cdzo72 is offline   Reply With Quote
Old 05-25-2010, 04:40 PM   #2
Microsoft MVP
 
johnwill's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2002
Location: S.E. Pennsylvania, US
Posts: 50,845
OS: Windows 7, XP-Pro, Vista, Linux

My System


Windows 7 has file permissions in the home versions, so I'd set the permissions of those folders to block sharing.

__________________
If TSF has helped you, Tell us about it! or Donate to help keep the site up!

Microsoft MVP - Windows Desktop Experience
johnwill is offline   Reply With Quote
Old 05-25-2010, 05:33 PM   #3
Registered Member
 
Join Date: Mar 2010
Location: Costa Rica
Posts: 63
OS: Windows 7 Ultimate 64 bit



Not sure where to set the file permissions, but when I go to my users folder, bar at the top says "share with" I choose "nobody" from the drop down menu, but that has no effect on the sharing.
__________________
cdzo72 is offline   Reply With Quote
Old 05-26-2010, 06:36 AM   #4
Microsoft MVP
 
johnwill's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2002
Location: S.E. Pennsylvania, US
Posts: 50,845
OS: Windows 7, XP-Pro, Vista, Linux

My System


You need to enable Advanced Sharing. In Windows Explorer, Tools, Folder Options, View, and disable the Sharing Wizard. There you'll be able to configure specific users for sharing.
__________________
If TSF has helped you, Tell us about it! or Donate to help keep the site up!

Microsoft MVP - Windows Desktop Experience
johnwill is offline   Reply With Quote
Old 05-26-2010, 07:08 AM   #5
Registered Member
 
Join Date: Mar 2010
Location: Costa Rica
Posts: 63
OS: Windows 7 Ultimate 64 bit



I've tried that also, has no effect.

On the Windows XP laptop I go to Network Places; I see two groups, Local Network which has the shared folders from the WIndows XP laptop and the second group is "The Internet" which has Users on XXToshiba. I choose the XXToshiba folder and I see two folders, one is the user folder I DON'T want to share and the other is the Public folder that I do want to share.
__________________
cdzo72 is offline   Reply With Quote
Old 05-26-2010, 07:30 AM   #6
Registered Member
 
Join Date: Mar 2010
Location: Costa Rica
Posts: 63
OS: Windows 7 Ultimate 64 bit



The folder I don't want to share even says network path not shared and not shared under the user name, also has the small padlock icon by it, BUT when I go to network and go the users (keep in mind I'm now looking at the folder from the computer where it is found) I see my folder and the public folder. My folder, the one I don't want to share does not have the padlock by it.

__________________
cdzo72 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 05:32 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts