Go Back   Tech Support Forum > Microsoft Support > Internet Browsers and Email > Mozilla/Firefox Browsers

Hyperlinks don't work in Thunderbird/Firefox

This is a discussion on Hyperlinks don't work in Thunderbird/Firefox within the Mozilla/Firefox Browsers forums, part of the Tech Support Forum category. Not sure if this is a Windows problem, Firefox problem or Thunderbird problem. A while back clicking on a link


Reply
 
Thread Tools Search this Thread
Old 03-24-2008, 06:03 PM   #1
Registered Member
 
Join Date: Mar 2008
Posts: 4
OS: Windows XP SP2



Not sure if this is a Windows problem, Firefox problem or Thunderbird problem.
A while back clicking on a link to any website that appeared in an email to me did not automatically open Firefox and go to that website. If I opened Firefox and then went back to the email and clicked on it, I would go to the website, but Firefox had to be opened first.
Now, all of a sudden, that is not working. Even if Firefox is open and I click on a link in an email, it does not go to the website. I have to copy the link to the clipboard first, then paste the link into my web browser.
I have no idea why this happened. I have gone through my Firefox and Thunderbird options and don't see anything there.
Any help would be appreciated.

Thanks,

Terry

__________________
ticktock01 is offline   Reply With Quote
Old 03-24-2008, 09:19 PM   #2
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

Hi Terry,

Did you set Firefox as your default browser? You can do that in Firefox but you want to set the system default too. Open the 'Program Access and Defaults' via the Start button or Control Panel and you can set both Firefox and Thunderbird as your default browser and mail client/news reader.

In Firefox it's - Tools > Options > Advanced > General > System Defaults.

Have you got any Link or Tab related extensions installed that could effect default behaviour like Tab Mix, Linky etc?

__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 03-28-2008, 04:27 AM   #3
Registered Member
 
Join Date: Mar 2008
Posts: 4
OS: Windows XP SP2



Keithy,
Thanks for your help, but I've done all that already and links still don't work. It is very annoying to have to copy and paste links into Firefox rather than just clicking on them.
Any other possibilities?

Terry
__________________
ticktock01 is offline   Reply With Quote
Old 03-28-2008, 05:39 AM   #4
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

I missed your reference to Thunderbird first time around Terry. Is this link behaviour (or lack of) affecting Thunderbird and Firefox? What about other browsers?

Also, you didn't mention if you had any extensions that could affect link behaviour.
__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 03-28-2008, 05:49 PM   #5
Registered Member
 
Join Date: Mar 2008
Posts: 4
OS: Windows XP SP2



The link behavior only affects links in my Thunderbird Email that link to websites in Firefox. Links in Firefox that link to other websites work fine. I don't have any other browsers. I uninstalled IE a while ago.

I do have several Firefox extensions. I will try uninstalling them and see if that makes a difference.
Thanks,
__________________
ticktock01 is offline   Reply With Quote
Old 03-28-2008, 05:58 PM   #6
Registered Member
 
Join Date: Mar 2008
Posts: 4
OS: Windows XP SP2



Unfortunately disabling my Firefox extensions didn't make a difference. Still have the same problem. I wonder if it could be a registry problem.
__________________
ticktock01 is offline   Reply With Quote
Old 04-06-2008, 03:28 AM   #7
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

Sorry for the delay.

So, the link problem is with Thunderbird. I'll go check a few pref's and see what I can dig up.

A thought has occurred to me in light of your last post or two. I don't know if you know, but there is an extension for Thunderbird called ThunderBrowse which allows you to open links within Thunderbird without opening your browser. Follow the link and check it out. I've been using it for a while and it's good.
__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 04-09-2008, 01:54 AM   #8
Registered Member
 
Join Date: Apr 2008
Posts: 1
OS: Windows XP Pro SP2



I recently encountered this problem as well. Being a fan of Firefox and Thunderbird, these were the default browser and email client. It actually seems the problem lies in Internet explorer and the way some of the updates change the way Windows handles these links??? I'm not sure exactly why or how, but I hadn't updated to IE7, simply because I didn't use IE, but upon being stumped for many days about this link problem I ran Windows update and installed IE7, because I was having a problem with IE Tab not quite working correctly as well. This completely fixed the link problem in Thunderbird as a not intended effect of trying to fix another smaller glitch I was having with IE Tab.

If you are having this link problem in Thunderbird and you haven't updated to IE7 do so and this should fix the problem if you've tried the other suggestions. This obviously is only valid with Windows...and likely only Windows XP.
__________________
jazzyrick is offline   Reply With Quote
Old 06-16-2008, 10:37 AM   #9
Registered Member
 
Join Date: Jun 2008
Posts: 3
OS: Win XP SP2


Confused

Quote:
Originally Posted by ticktock01 View Post
Unfortunately disabling my Firefox extensions didn't make a difference. Still have the same problem. I wonder if it could be a registry problem.
Hi ticktock01,

Just wondering if you were ever able to resolve your Thunderbird / Firefox web link problem? I've got the same problem and I've tried ALL of the various recommended solutions to no avail (in fact the problem persisted even after I did a total reinstall of XP - but that's another story).

Any ideas / help would be appreciated.
__________________
fluteman is offline   Reply With Quote
Old 08-01-2008, 05:00 AM   #10
Registered Member
 
Join Date: Aug 2008
Posts: 5
OS: XP sp2



This happens to me, too. Only when I click a link, Thunderbird completely freezes up and I have to kill it in Task Manager and restart. I can't click on any other link or view any other message for that matter. I can neither delete a message or move it to a different folder until I've restarted Thunderbird. I am baffled by this error as well as quite perturbed.
__________________
jmattingly is offline   Reply With Quote
Old 08-01-2008, 07:19 AM   #11
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

Just a thought, but have you checked that Java is enabled in TB prefs?

....another thought! You may as well check Javascript is enabled too.
__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 08-02-2008, 05:35 AM   #12
Registered Member
 
Join Date: Aug 2008
Posts: 5
OS: XP sp2



both enabled
__________________
jmattingly is offline   Reply With Quote
Old 08-03-2008, 01:22 AM   #13
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

Did you check your firewalls or any other program you have that may block Internet Access. I suppose the quickest way to check is to turn off your firewall (or spyware etc that could prevent access to Internet) and try clicking the links again.

If you are not sure you have set Firefox as your default browser you can force it to be default browser by clicking Start > Run
then enter text > firefox.exe -silent -setDefaultBrowser

The normal way to set it of course would be via Start > Set Program Access and Defaults
__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 08-03-2008, 09:41 AM   #14
Registered Member
 
Join Date: Jun 2008
Posts: 3
OS: Win XP SP2


EEK!

Quote:
Originally Posted by keithy397 View Post
Did you check your firewalls or any other program you have that may block Internet Access. I suppose the quickest way to check is to turn off your firewall (or spyware etc that could prevent access to Internet) and try clicking the links again.

If you are not sure you have set Firefox as your default browser you can force it to be default browser by clicking Start > Run
then enter text > firefox.exe -silent -setDefaultBrowser

The normal way to set it of course would be via Start > Set Program Access and Defaults
I have checked and double checked that Firefox is my default browser, totally disabled my internet security software, made sure that Java and Jscript is enabled, etc. - I even totally uninstalled and reinstalled Thunderbird and I still have the problem. However, when I use Pegasus
as my email client, all of the web links do work, so I know that it has to be related to Thunderbird. This is driving me nuts!
__________________
fluteman is offline   Reply With Quote
Old 08-04-2008, 05:41 AM   #15
Registered Member
 
Join Date: Aug 2008
Posts: 5
OS: XP sp2



I'm quite sure it's not a firewall or spyware program because I can download e-mail, send e-mail, and open attachments in Thunderbird. And I can do everything in Firefox. However, it just isn't convenient having to open each one of my e-mail accounts in Firefox when I can manage all of them in Thunderbird.
__________________
jmattingly is offline   Reply With Quote
Old 08-07-2008, 04:51 AM   #16
TSF Enthusiast
 
keithy397's Avatar
 
Join Date: Jul 2004
Location: Anglesey, North Wales
Posts: 553
OS: XP Pro


Send a message via MSN to keithy397

Quote:
Originally Posted by fluteman View Post
I even totally uninstalled and reinstalled Thunderbird and I still have the problem. However, when I use Pegasus
as my email client, all of the web links do work, so I know that it has to be related to Thunderbird. This is driving me nuts!
Did you install over the top of the existing prog folder? If so, try a clean install. Delete all in the prog folder after uninstall and before re-installing. All your data will be ok as it is stored in a different location.

This is probably something so easy to correct, a good (self) bum kicking will be required when resolved! In the meantime, I'll do some testing.

Did you try the IE update thing jazzyrick suggested in an earlier post?
__________________
Cheers,
keithy397 is offline   Reply With Quote
Old 08-08-2008, 11:59 AM   #17
Registered Member
 
Join Date: Jun 2008
Posts: 3
OS: Win XP SP2



Quote:
Originally Posted by keithy397 View Post
Did you install over the top of the existing prog folder? If so, try a clean install. Delete all in the prog folder after uninstall and before re-installing. All your data will be ok as it is stored in a different location.

This is probably something so easy to correct, a good (self) bum kicking will be required when resolved! In the meantime, I'll do some testing.

Did you try the IE update thing jazzyrick suggested in an earlier post?
Actually, the problem has persisted even after I built a totally rebuilt my system from scratch by installing a clean version of XP SP2, applying all of the security updates, and installing a totally new instance of Thunderbird 2.0.0.14 and Firefox 3.x.
__________________
fluteman is offline   Reply With Quote
Old 08-09-2008, 06:16 AM   #18
Registered Member
 
Join Date: Aug 2008
Posts: 5
OS: XP sp2



I wonder what the effect is with FF 2.x.x? I recently installed FF 3 and TB recently came up with this problem--perhaps a relationship?
__________________
jmattingly is offline   Reply With Quote
Old 08-27-2008, 06:42 PM   #19
Registered Member
 
Join Date: Aug 2008
Posts: 2
OS: xp



had the same problem...(If you are not sure you have set Firefox as your default browser you can force it to be default browser by clicking Start > Run
then enter text > firefox.exe -silent -setDefaultBrowser) this fixed mine
thank-you
__________________
gtlenny is offline   Reply With Quote
Old 08-28-2008, 04:54 AM   #20
Registered Member
 
Join Date: Aug 2008
Posts: 5
OS: XP sp2



I got my problem fixed. I was looking in FF's options because I noticed whenever I clicked a mailto:x@x.com link, it kept opening Outlook. When I changed the default mail client to Thunderbird, the problem magically went away.

__________________
jmattingly is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 01:16 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts