Go Back   Tech Support Forum > Microsoft Support > Internet Browsers and Email > Mozilla/Firefox Browsers

Fonts messed up - Weird symbols/letters

This is a discussion on Fonts messed up - Weird symbols/letters within the Mozilla/Firefox Browsers forums, part of the Tech Support Forum category. Recently I've had this problem with my browser (or comp, I'm not sure if I'm missing a font or what).


Reply
 
Thread Tools Search this Thread
Old 05-09-2010, 04:56 PM   #1
Registered Member
 
Join Date: Nov 2009
Location: MD, USA
Posts: 154
OS: xp Media edition



Recently I've had this problem with my browser (or comp, I'm not sure if I'm missing a font or what). On some webpages the fonts show up as weird letters with symbols. I have two screenshots. And just a few weeks ago these web pages were working fine. I have two accounts on my computer. I use Firefox on both. On one account, it works fine, on the other I get the weird font. So it's not the webpage.

Screenshots:

and:
http://yourimg.in/i/tuwg1bfs.jpg
Web Address for the above screen shot webpage:
http://www.bside-productions.com/9-amazing-web-fonts/

__________________
An Alien is offline   Reply With Quote
Old 05-10-2010, 07:03 AM   #2
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 9,844
OS: Windows 7 Pro, ME, Vista. In the past CP/M, DOS, Windows 95, 2000 & 98SE



Tools>Options>Content. Select font and color. Also View>Character Encoding. Choose Western (ISO-8859-1)

__________________



The stability of an OS is in direct proportion to the stability of the user.
Corday is online now   Reply With Quote
Old 05-10-2010, 12:22 PM   #3
Registered Member
 
Join Date: Nov 2009
Location: MD, USA
Posts: 154
OS: xp Media edition



Quote:
Originally Posted by Corday View Post
Tools>Options>Content. Select font and color. Also View>Character Encoding. Choose Western (ISO-8859-1)
Default font is Times New Roman. And the character Encoding is Western (ISO-8859-1) but I still have the same problem.
__________________
An Alien is offline   Reply With Quote
Old 05-11-2010, 01:24 PM   #4
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 9,844
OS: Windows 7 Pro, ME, Vista. In the past CP/M, DOS, Windows 95, 2000 & 98SE



This doesn't seem possible. Usually the problem is you don't have the correct glyphs, but if one account gets it right then the other should also. Make sure fonts are for "Western" at top of Content screen. At the bottom of that screen the View selected encoding should also agree with the one you set in Character Encoding. One more possibility is that your profile is corrupted. See Mozilla instructions for deleting and starting a new FF profile. If you have add ons, see what happens if you disable them one at a time.
__________________



The stability of an OS is in direct proportion to the stability of the user.
Corday is online now   Reply With Quote
Old 05-14-2010, 10:37 PM   #5
Registered Member
 
Join Date: Nov 2009
Location: MD, USA
Posts: 154
OS: xp Media edition



Okay, now my the other user on the same comp is starting to have the problem too. But it's not the same pages.

Here's a screenshot of the second user's font while typing in a captcha. And when I copy and paste it, it comes out as what I was originally typing in the keyboard before it turning into weird symbols.
__________________
An Alien is offline   Reply With Quote
Old 05-15-2010, 12:26 PM   #6
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 9,844
OS: Windows 7 Pro, ME, Vista. In the past CP/M, DOS, Windows 95, 2000 & 98SE



Change the default font. If that doesn't work, reinstall FF, but start new profiles. If problem persists, you definitely have malware present.
__________________



The stability of an OS is in direct proportion to the stability of the user.
Corday is online now   Reply With Quote
Old 05-16-2010, 06:00 AM   #7
Registered Member
 
terrawarra's Avatar
 
Join Date: Mar 2007
Location: Bundanoon, Australia
Posts: 139
OS: XP

My System


Quote:
Originally Posted by An Alien View Post
Default font is Times New Roman. And the character Encoding is Western (ISO-8859-1) but I still have the same problem.
Following the info by Corday,.. tools > options > content > fonts & colours > advanced... is the box checked: "allow pages to choose their own fonts, instead of my selections above"
If it isn't checked,. give it a try and see if that helps.
__________________
terrawarra is offline   Reply With Quote
Old 05-16-2010, 02:04 PM   #8
Registered Member
 
Join Date: Nov 2009
Location: MD, USA
Posts: 154
OS: xp Media edition



It's already checked. I'm about to reinstall FF, but how do I backup my bookmarks?
__________________
An Alien is offline   Reply With Quote
Old 05-16-2010, 03:27 PM   #9
Registered Member
 
terrawarra's Avatar
 
Join Date: Mar 2007
Location: Bundanoon, Australia
Posts: 139
OS: XP

My System


Try MozBackup

http://download.cnet.com/MozBackup/3...-10260383.html

__________________
terrawarra is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:09 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts