Go Back   Tech Support Forum > Microsoft Support > Internet Browsers and Email > Other Browsers


Chrome causing high CPU usage while watching videos.

This is a discussion on Chrome causing high CPU usage while watching videos. within the Other Browsers forums, part of the Tech Support Forum category. So i have this problem for a long time but i never really did anything about it until today.When i


Reply
 
Thread Tools Search this Thread
Old 09-10-2016, 10:50 AM   #1
Registered Member
 
Join Date: Dec 2014
Location: Greece
Posts: 64
OS: Windows 10



So i have this problem for a long time but i never really did anything about it until today.When i watch a video on youtube with chrome 720p 60fps my CPU usage goes up to 98% and then after 4-5 seconds it drops to like 60-70% but the video is not smooth and there are some video spikes so its really annoying.Tried microsoft edge on the same video 720p 60fps and the CPU usage went max 17% then i saw it on 1080p 60fps and max was 25%.So obviously there is something wrong with chrome.I checked the tool section on chrome and the task manager showed that the only thing using CPU was the video so at this point i dont really know what to do.

I have tried many solutions but none of them worked.These are the sollutions i tried.

My pc is formated so unistall and install chrome wont work.
Disable "Use a prediction service to load pages more quickly"
Disable "Use hardware accerelation when available"
Tweaked some settings on chrome://flags
Disable/Deleted all plug-ins i had.


So i would appriciate if any of you guys have an tips cause i really want to stay on chrome.I dont want to swap on mozilla or Edge.Thanks in advanced!


Pc Specs :
Intel Core 2 Quad Q6600 Overclocked at 3.00Ghz
Nvidia GTX 750Ti MSI Twin Frozr
Mushkin 4GB DDR2 RAM(Saddly)
Asus P5KPL/1600 Socket 775 (Saddly)
600Watt Thermaltake Litepower Black Edition
andrynuim is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
High CPU usage hangs
Hi all, Every now and then (averages about once a day) my computer goes into high usage, my cursor goes really slow and after 3 seconds, nothing. Can't alt-tab or anything. My CPU fan goes up and my HDD goes like nuts. Sometimes it happens in game, sometimes it happens when I'm just listening to...
Sayid Gishta BSOD, App Crashes And Hangs 5 06-15-2013 03:44 PM
How do i disable intel's graphics?
I know that my PC comes with something similiar to a graphics card, it is even wired into my windows 8 settings all by itself. I am having a tech problem, and i believe the display card is the main problem as everything else seems to check, how can i disable it and go back to the display card-less...
aayushagra Video Card Support 37 03-25-2013 10:29 AM
Many programs have lag spikes
Recently without any apparent reason every random amount of time when im using a program it randomly hangs for like a second or two. Idk if it affects all programs but it happens with the video player games and internet browser and audio player. If i switch windows i can see that the rest of...
rayquaza88 Windows 7 , Windows Vista Support 41 05-19-2012 10:11 AM
Abnormally High CPU Usage
First off, the computer specs don't seem to be relevant for this specific issue but I'll post them anyways. Processor: Pentium D945 3.2ghz dual-core Ram: 2gb Graphics Card: Nvidia GeForce GT220 Yes, I know - nowadays that isn't much and it's worth upgrading anyways but that's not the point. ...
enskyment Motherboards, Bios & CPU 21 02-02-2012 01:45 PM
CPU Fan Loud
I'm sorry if this is not the right place, but I have no idea where to put this. So, I've had this computer for about 2 years now, and recently the computer has been making some loud noises. Starting yesterday, the computer's been making very worrying buzzing noises. Through a variety of...
orionstar Overclocking 13 03-15-2011 06:59 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:14 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 2001 - 2015, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts

 

Partially Powered By Products Found At Lampwrights.com