Go Back   Tech Support Forum > Hardware Support > Printer Support

Error E-90 on Epson stylus Photo RX520

This is a discussion on Error E-90 on Epson stylus Photo RX520 within the Printer Support forums, part of the Tech Support Forum category. While powering on the printer it gets stuck and the front panels just shows E-90.. What does this error mean...


Closed Thread
 
Thread Tools Search this Thread
Old 09-08-2007, 09:16 AM   #1
Registered Member
 
Join Date: Sep 2007
Posts: 1
OS: Win xp sp2


Cry

While powering on the printer it gets stuck and the front panels just shows E-90.. What does this error mean... what is the actual problem.. how do i solve this.. pls. help....urgent..

__________________
Rupeshk is offline  
Old 09-10-2007, 03:07 AM   #2
Registered Member
 
Join Date: Sep 2007
Posts: 1
OS: xp



Quote:
Originally Posted by Rupeshk View Post
While powering on the printer it gets stuck and the front panels just shows E-90.. What does this error mean... what is the actual problem.. how do i solve this.. pls. help....urgent..

__________________
beco is offline  
Old 11-04-2007, 05:51 AM   #3
Registered Member
 
Join Date: Nov 2007
Posts: 1
OS: OSX



Did you ever get a response to your question? My printer did the same thing over the weekend.
__________________
Shane67 is offline  
Old 11-05-2007, 09:00 PM   #4
I helped the forums.
 
twajetmech's Avatar
 
Join Date: Jul 2004
Location: LGA, NYC
Posts: 2,394
OS: XP-Pro Sp2 & XP-Pro Sp2 Tablet Edition, Vista Ultimate, Win 7

My System


Hello and welcome to the TSF. Best I could gather from the net, an e-90 error is a fatal error with the printer itself, the only solution is to contact Epson if the unit is still under warranty. Otherwise I understand the fix is more cosstly than the printer. The error seems to be reported most when a new black cart. is installed, you could try reseating the cart, powering down the unit for 15 min and then plugging back in and see if that will reset the printer. You can also try the SCC reset utility....http://www.ssclg.com/download/sscserve.exe
twajetmech is offline  
Closed Thread
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 04:36 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts