Go Back   Tech Support Forum > Hardware Support > Laptop Support

Wireless problems with Acer Aspire One netbook

This is a discussion on Wireless problems with Acer Aspire One netbook within the Laptop Support forums, part of the Tech Support Forum category. Hi, I'm having trouble connecting to the wireless on a new laptop I just bought! The model is an Acer


Closed Thread
 
Thread Tools Search this Thread
Old 02-02-2011, 08:54 PM   #1
Registered Member
 
Join Date: Feb 2011
Posts: 2
OS: WindowsXP



Hi, I'm having trouble connecting to the wireless on a new laptop I just bought! The model is an Acer Aspire One D255. I tried connecting and it didnt work; no error message, just the little icon in the corner with a red X next to it, and when I put my cursor over it it says "not connected"

I googled on my PC and found out that a LOT of people have similar problems with this laptop and it's because of the wireless module inside being bad (which for reference is an Atheros AR5B95). I couldnt find any good fixes and it seems the only way to actually make it work is to open up the laptop and fit a new wireless module (which I am not skilled enough to do!!) I did try installing the latest driver for it though, which didn't help anything.

Although I really need wireless, I did try plugging in the ethernet cable into the laptop directly from my router to experiment, and that doesnt even work either. Although it says its connected when I do this, I can't load any webpages.
Surely that should work even if the wireless adapter doesn't, because its not using wireless that way. I have no clue whats wrong. My PC internet works fine through wireless or ethernet by the way so it's definitely the laptop.

This is the laptop (from the same page I bought it from too)
Acer Aspire One D255 Netbook 1GB RAM 160GB HDD - Laptops & PCs

If I buy a wireless USB adapter will that work? What should I do? I desperately need this with internet access for when my studies start next week! :(

__________________
PixieGirl1 is offline  
Old 02-02-2011, 09:57 PM   #2
Registered Member
 
Join Date: Feb 2011
Posts: 2
OS: WindowsXP



I made a little bit of progress but it only led to more confusion!! o_O

I messed around with my internet settings a little bit and was able to get the Wireless icon to display as Connected instead of having the little red x.

When I load up internet explorer I can type any internet address and it will actually come up with the title in the top bar above the address bar (for example, facebook.com comes up with "Welcome to Facebook - log in, signup or learn more" and ask.com says "Ask.com - What's Your Question?") this proves to me that my laptop is actually connecting and getting information from the internet.. BUT I get absolutely nothing on any page I try to connect to. No "failed to connect", just a blank white screen on every page.

I installed Firefox to see if that would display more, and its actually worse than Internet Explorer because that doesn't even come up with the title at the top, it just stays "loading" forever.

__________________
PixieGirl1 is offline  
Old 02-03-2011, 01:47 PM   #3
Registered Member
 
Join Date: Sep 2009
Posts: 24
OS: Mac OS X Lion



It could be that you have wireless adapter set to power saving which (on Acer One at least) just makes it unusable. Go to Control Panel -> System -> click on Hardware tab and then Device Manager. There expand Network Adapters, right click on Atheros and Properties. On the opened window click Advanced tab and under "Property" find Power Save Mode. Set it to off.
__________________
Melkijad is offline  
Old 02-23-2011, 02:32 PM   #4
Registered Member
 
Join Date: Feb 2011
Posts: 1
OS: windows 7 ultimate



I had the same problem. I updated the bios to the newest version and everything works fine now. when you update the bios, i went to the netbook D255e instead of D255 to get the bios off of the Acer website. Just open up the file folder, click on widows, then click on the PAV file and have it install the bios through windows. I have tried for 5 days to fix this with all other troubleshooting and this was the only thing that fixed it. I have 3 of the exact same netbook Acer Aspire One D255
__________________
mouradian is offline  
Old 04-13-2011, 01:33 PM   #5
Registered Member
 
Join Date: Apr 2011
Posts: 1
OS: win xp



Quote:
Originally Posted by mouradian View Post
I had the same problem. I updated the bios to the newest version and everything works fine now. when you update the bios, i went to the netbook D255e instead of D255 to get the bios off of the Acer website. Just open up the file folder, click on widows, then click on the PAV file and have it install the bios through windows. I have tried for 5 days to fix this with all other troubleshooting and this was the only thing that fixed it. I have 3 of the exact same netbook Acer Aspire One D255
Did you experience any issues when restarting the netbook after the bios flash? My netbook runs win xp, I downloaded bios version 3.15 and flashed the bios, everything seemed fine but now windows want start, I get the windows icon page but that’s it, it won’t go past that point, my netbook just keeps on restarting again and again.
Can anyone help?
__________________
eezzss1 is offline  
Old 05-02-2011, 09:27 AM   #6
Registered Member
 
Join Date: May 2011
Posts: 1
OS: xp



Quote:
Originally Posted by Melkijad View Post
It could be that you have wireless adapter set to power saving which (on Acer One at least) just makes it unusable. Go to Control Panel -> System -> click on Hardware tab and then Device Manager. There expand Network Adapters, right click on Atheros and Properties. On the opened window click Advanced tab and under "Property" find Power Save Mode. Set it to off.
it did work but you have to restart your laptop before it can work

__________________
superhero is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer Aspire Wireless Connection
My son's Acer Aspire 5517 laptop loses it's wireless connection about every 15 minutes. We use a Belkin G Router, but non of our other computers (HP's and Dells) have this problem. Can anyone offer some guidance?
jimlyn4 Laptop Support 1 05-19-2011 09:09 AM
Multiple problems with autistic son's Acer Aspire 5551-2384 Notebook
Hi, my son's Acer Aspire 5551-2384 Notebook is just a week shy of being 6 months old. We've had a lot of ongoing issues; but, not being familiar with computers, I figured it was something my son was doing. The problems are occurring much more frequently (several to many times a day), and now I...
Loyal Laptop Support 51 02-24-2011 11:42 AM
Acer Aspire 5315 problems
Hey guys. A friend of mine spilt coffee on her Acer Aspire 5315 and it shut down. She didnt try it again since as she thought she had ruined it. However she gave it to me to look at it, and it powered on fine and came to the logon screen. I left it for 15mins to make sure everything was...
TheKillerQueen BSOD, App Crashes And Hangs 25 01-26-2011 03:03 PM
Acer Aspire 3820TG Ethernet controller problems
Hi, My Acer aspire 3820TG recently got problems with the internet connection. I live in a student dorm at the moment and there i connect to the internet directly from a cable. But now when i connect the cable to my acer nothing happens. Under device managament there is now a "Ethernet...
12345 Driver Support 5 01-15-2011 05:44 AM
Wireless issue - acer aspire 5920
This thread comes up high in search results, but low in helpfulness. The PDF file linked, which is the dream file un-mentioned anywhere else, tells how to activate Wireless without the button, which is really useful when the button is broken. Too bad it's now protected by a login screen. My...
TomMBILF Networking Support 1 01-06-2011 12:15 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:58 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts