Go Back   Tech Support Forum > Hardware Support > Laptop Support

Toshiba keyboard problems

This is a discussion on Toshiba keyboard problems within the Laptop Support forums, part of the Tech Support Forum category. I have a toshiba satelite l300D but my keyboard is playing up, it seems certain letters are linked so for


Closed Thread
 
Thread Tools Search this Thread
Old 03-22-2011, 03:37 AM   #1
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



I have a toshiba satelite l300D but my keyboard is playing up, it seems certain letters are linked so for example when I press the p key on my keyboard pk appears onscreen, and when i type k, pk appears onscreen.
This happens with the following keys:
I appears as -i onscreen, and - key shows as -i
, appears as ,[ and vice versa
space bars makes my browser bar dissapear and reappear
0 shows as 80 onscreen and 8 as 80
Can you help please?

__________________
haynes86 is offline  
Old 03-22-2011, 03:48 AM   #2
Registered Member
 
Join Date: Mar 2011
Posts: 2
OS: XP



this could be that your keyboard has dust etc in side it. so you need to try and clean it out by, using compressed air to get underneath the keys also get a cotton bud or something similar to clean any stickiness off the actual buttons. if this does not work then it is probably a fault with your computer and you should try taking it back to where you got it from if it is under warrenty.

__________________
tjblondie is offline  
Old 03-22-2011, 04:14 AM   #3
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



not sure its dust as the problems are not 'random' but have cleaned -it and it didnt offer a solution, unfortunately the laptops no longer covered by warranty. thanks anyway
__________________
haynes86 is offline  
Old 03-22-2011, 05:14 AM   #4
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,582
OS: windows 7

My System


hi haynes86 welcome to tsf,

hook up a usb keyboard see if it does the same thing. if thats ok i would start by taking keyboard out and re-seat the cable. be careful not to break the zif connector
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now  
Old 03-22-2011, 10:54 AM   #5
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



thanks for the reply i have tried an unsucessful attempt to use an external keyboard but unfortunately this didnt solve the problem
__________________
haynes86 is offline  
Old 03-22-2011, 11:30 AM   #6
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,582
OS: windows 7

My System


so you stated you hooked up a usb keyboard and it did the same thing? or the keyboard did not work at all?
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now  
Old 03-22-2011, 12:02 PM   #7
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



The usb keyboard did the same thing...Would it be worth restoring the laptop to factory sett-ings? Thanks again for your help
__________________
haynes86 is offline  
Old 03-22-2011, 01:34 PM   #8
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,582
OS: windows 7

My System


goto device manager and uninstall the keyboard and reboot. It will install driver upon startup.
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now  
Old 03-22-2011, 03:33 PM   #9
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



No unfotunately the problem still persists.
__________________
haynes86 is offline  
Old 03-22-2011, 03:45 PM   #10
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



Sorry meant to say tri-ed it but problem still persists...
__________________
haynes86 is offline  
Old 03-22-2011, 04:32 PM   #11
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 52,356
OS: win 7 pro/ultimate/xp vm



Hi have you tried going to the toshiba support page for your model here is one model
check if it is yours Model Content Page on page 2 near the bottom is the touchpad driver try installing it provided it is your model if not then look yours up
__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Old 03-23-2011, 03:14 PM   #12
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



Still no luck, installed the new driver to no avail. Any more ideas at all?
Thanpks again
__________________
haynes86 is offline  
Old 03-23-2011, 03:18 PM   #13
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 52,356
OS: win 7 pro/ultimate/xp vm



Does it work ok in the bios is it visible in the bios under usb device or similar
__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Old 03-23-2011, 04:28 PM   #14
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,582
OS: windows 7

My System


how long ago did this start happening? can you try a restore point?
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now  
Old 03-24-2011, 10:04 AM   #15
Registered Member
 
Join Date: Mar 2011
Posts: 8
OS: vista



It started in October but my only restore points are thereafter...
__________________
haynes86 is offline  
Old 03-24-2011, 03:52 PM   #16
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,582
OS: windows 7

My System


look here and see if you could try a repair install
Repair Install For Vista - Vista Forums

__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Keyboard keys messing up
Hi guys, My friend has a Toshiba Satellite laptop and he is having some issues with the keyboard.. he said he spilled some liquids on it before. First, I tried reformatting the laptop and resetting the BIOS and the problem still exists. I tried an external keyboard and it works fine, so it's...
dem0x7 Laptop Support 6 02-27-2011 05:43 PM
redirect to mywebface, mywebsearch, and wizard101
For the past few days, I have been getting redirected to mywebface or wizard101.com when I visit some websites, not all, but they are normal and safe websites that I visit and have always visited, but now I'm getting this redirection. I will refresh the website and it will redirect again. This only...
woodman123 Resolved HJT Threads 19 02-16-2011 09:13 PM
Keyboard Problems
Alright, so I'm typing this from my onscreen keyboard. My computer's keyboard keys: n, a, shift, and enter are not working anymore. I thought it was a virusy email, so I ran both Spybot and Malaware, but whatever they fixed wasn't the problem. I'm not sure how to reinstall and uninstall drivers....
Mkay Windows 7 Support, Windows Vista Support 5 02-02-2011 11:36 AM
[SOLVED] HP pavillion Dv8000 KeyBoard Problems
Hello. I recently spilled a drink on my laptop keyboard. Turned it immediatly off, I let it dry for a few day and tried using my keyboard to find it would work half the time. Figured I shorted it out. Replaced the keyboard and the problem is still there. I made sure everything was plugged inn....
NinjaDust Laptop Support 11 01-18-2011 03:38 PM
Toshiba Satellite P205D need help with programs
I have had my laptop for 3 to 4 years, and I need to make some space to include Microsoft Word 2010 from Office Pro. Apparently my dad said it is an office type of laptop and bought it for me; however, I myself am a student so I don't know if some programs apply to me. Here are the programs that...
RelentlessX Laptop Support 1 01-07-2011 11:42 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 05:03 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts