Go Back   Tech Support Forum > Hardware Support > Laptop Support

LED screen Discoloration

This is a discussion on LED screen Discoloration within the Laptop Support forums, part of the Tech Support Forum category. Hello all, I have a HP dv3000 with a 13.3-inch, WXGA BrightView LED display. there is some discoloration with certain


Closed Thread
 
Thread Tools Search this Thread
Old 06-22-2010, 09:01 AM   #1
Registered Member
 
Join Date: Jun 2010
Posts: 2
OS: Win7 64



Hello all,

I have a HP dv3000 with a 13.3-inch, WXGA BrightView LED display.

there is some discoloration with certain colors.






At first i thought it was the display cable, so i replaced it. That unfortunately did not fix the problem, my next guess was going to be a bad inverter, but it is an LED screen and does not have one as a LCD would.

The closest thing I can find that might be an inverter is this circuit board, i think it may be the problem.





Any thoughts on what the problem might be is welcome.

Thanks.

__________________
basketcase210 is offline  
Old 06-23-2010, 07:55 PM   #2
Registered Member
 
Join Date: Jun 2010
Posts: 2
OS: Win7 64



/bump

__________________
basketcase210 is offline  
Old 06-23-2010, 08:29 PM   #3
TSF Enthusiast
 
Kharm's Avatar
 
Join Date: Jan 2010
Location: Texas
Posts: 351
OS: linux ubuntu and Win7 64bit



I think that might in fact be a inverter. I looked up dv3015 on hppartsurfer and it has a part 468798-001 for a inverter board. I'm just guessing at model since I don't know your exact model outside it being a dv3000. I hardly work on HP, but new gateway and acer units that use led displays have that built into the display. Event he plug on that circuit board you took a picture of looks typical of the same plug thats on the led display.

Normally I would say the inverter has nothing to do with your video feed it only supplies back light, but in your case I'm not so sure. As the led displays that have that circuit board built in also only have one connector that apparently gives video feed and power to the led back light. How many cables plug into the lcd you have? Is there one for that circuit board and one coming from the system board? Or is it from the system board to that board then to the lcd? If the ladder it could very well be that board that is bad.

I have seen that issue before many times in normal lcds and its usually either the lcd cable or the lcd itself, and sometimes its the damn lcd connector on the system board with a cracked solider joint (rare).

might still be in warranty man. http://h20000.www2.hp.com/bizsupport...odTypeId=12454

check it out and facilitate that sucker. Unless you got an extended warranty then send it to them instead (free shipping). Good luck
__________________
Kharm is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:20 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts