Go Back   Tech Support Forum > Hardware Support > Laptop Support

Laptop battery won't charge/adapter LED blinking

This is a discussion on Laptop battery won't charge/adapter LED blinking within the Laptop Support forums, part of the Tech Support Forum category. Hello! I apologize in advance if this question has been addressed before. I'm having a difficult time finding a thread


Reply
 
Thread Tools Search this Thread
Old 10-09-2011, 04:57 AM   #1
Registered Member
 
Join Date: Mar 2008
Posts: 1
OS: XP SP2



Hello! I apologize in advance if this question has been addressed before. I'm having a difficult time finding a thread that is similar to the problem I'm having.

I have a Toshiba Tecra M7 that has been having power issues. I noticed that the power jack was loose on the laptop and whenever I would turn on my computer, the battery led on the laptop would start blinking, the led on the adapter brick would blink as well, and the computer would shut down. I found that by wiggling the adapter, I could sometimes get the computer to stay on.

Recently, I decided to change the jack since it was loose. Since it's the type connected by a harness, it was a fairly easy and straightforward replacement. Following the replacement, my computer's issue of not receiving sufficient power seemed to be lessened, so I assume that was a part of the problem. Now my laptop will actually turn on with the battery in and the adapter plugged, but the battery doesn't always charge. I have to actually position the adapter a certain way in the laptop jack before it charges. I also have a hard time getting the laptop to run on just AC power without the battery, and have to maneuver the charger tip to get the computer to turn on.

If I unplug the adapter from the laptop, the brick LED stays on, though. Is it likely that the adapter needs replacing? Or is there some other possible problem? It's one of those Targus adapters with the changeable tips.

Sorry if all that is confusing. I can try to be a little clearer if need be. Thanks so much in advance for any assistance!

__________________
LilSlugger is offline   Reply With Quote
Old 10-09-2011, 07:18 AM   #2
Hardware Tech Team
 
makinu1der2's Avatar
 
Join Date: Jan 2008
Location: Florida
Posts: 14,884
OS: Win7,Win XP,PC LinuxOS

My System


There may be a problem with power adapter? Check the tip for any problems?

See if you can test with another power adapter.
__________________
makinu1der2 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
New laptop battery not functioning.
I don't know if there is an answer for this... I ordered a new laptop battery for my MSi GT735 notebook. It arrived after a very long time (got here a week ago after 4 weeks of shipping). Now, while watching a YouTube video stream, the laptop shut off without warning. Upon further...
Thundaar Laptop Support 3 09-30-2011 08:18 AM
Dead battery now dead laptop
I bought a refurbished ibm thinkpad T60 a few months ago. It's been great until a few days ago when the battery totally died. I removed the battery and plugged the laptop into the wall outlet so I could use it until I bought a new battery. Last night I shut it down and unplugged it and now today,...
mloveskirk Laptop Support 1 09-26-2011 04:13 AM
Odd laptop motherboard/RAM issue
Hello all, I'm a new member here looking for some assistance with an HP laptop that I have. I posted my issues in another forum, so please forgive me for copying and pasting my problem. ORIGINAL ISSUE: Alright, well I've got a really strange laptop problem that I'm looking for some...
bobbylx Laptop Support 1 03-06-2011 10:18 PM
Laptop powers on with battery but not ac adapter.
I have a Samsung R580 that will power up just fine on battery power, but when the battery ran out and it turned off I tried to plug in the ac adapter and it doesnt power on ( the light on the power supply lights up), nor does it charge the battery. Is it the power supply or the laptop? If it is the...
jacksi6 Laptop Support 3 01-15-2011 10:00 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 09:02 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts