Go Back   Tech Support Forum > Hardware Support > Laptop Support

Keyboard and mouse not working :(

This is a discussion on Keyboard and mouse not working :( within the Laptop Support forums, part of the Tech Support Forum category. So, the problem is, the keyboard and mouse are not working, so i cannot do anything on my computer (laptop).


Reply
 
Thread Tools Search this Thread
Old 01-18-2012, 05:42 AM   #1
Registered Member
 
Join Date: Jan 2012
Posts: 4
OS: winXP sp3


Roll Eyes

So, the problem is, the keyboard and mouse are not working, so i cannot do anything on my computer (laptop).

The problems began yesterday, after I turned automatic updates ON, and downloaded a lot of updates and I installed them (77 of them) :D After that, I restarted computer and it worked after startup (however, there was one error, MOM.exe, application failed to start). I went on the internet to search about that error, it was something with ati catalyst control center, I dont think that error has anything with keyboard and mouse not working, but...? And computer worked about 10 minutes after those updates, and then it froze. I restarted it, and since then, keyboard and mouse are not working.

And now, every time i reboot computer, Windows boots just fine, it starts, it connects to a wireless network, even downloads updates, but keyboard and mouse are not working. Also, USB ports are not working, I tried inserting USB flash stick but nothing happens, even that little light on usb stick dont work. I connected mobile phone via USB cable to computer, and nothing happens, but at least my mobile phone battery is charging. :)
I tried inserting windows CD, and it starts just fine when pc is on. When I reboot the computer, I cannot go into bios and cannot start in safe mode because keyboard is not working. I cannot even start new installation of windows because when it says, press any key to boot from cd, it doesnt work :D Only thing i can to is to turn it off or restart.

However, when computer goes automatically to stand-by mode, and I press a button on keyboard, it awakes :D I can also change background lighting on display with keyboard buttons (Fn + L, R arrows)

Computer is acer aspire 5100 series laptop, win xp sp3, turion 2.0 ghz, 2 gb ram, ati xpress 1100...never had problem like this before. Please help meeee, and sorry if my english is not perfect...

__________________
tekun is offline   Reply With Quote
Old 01-18-2012, 11:52 AM   #2
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 53,865
OS: win 7 pro/ultimate/xp vm



Hi and welcome to TSF try tapping F8 as the computer boots and then choose last known good configuration

__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline   Reply With Quote
Old 01-19-2012, 06:04 AM   #3
Registered Member
 
Join Date: Jan 2012
Posts: 4
OS: winXP sp3



No, sorry, I wrote already that it doesnt work... :(

I'll try with portable linux distribution that starts itself automatically from cd :)
__________________
tekun is offline   Reply With Quote
Old 01-19-2012, 09:46 AM   #4
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 53,865
OS: win 7 pro/ultimate/xp vm



What happens if you try to enter the bios from boot.

have you tried the troubleshooting steps here Black Screen Issues and Troubleshooting
__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline   Reply With Quote
Old 01-20-2012, 04:30 AM   #5
Registered Member
 
Join Date: Jan 2012
Posts: 4
OS: winXP sp3



Couldn't enter bios because my keyboard didn't work :D

Thanks for that guide you posted me, but I already had read and tried similar things. Me and my friend disassembled my laptop, removed and reinserted the RAM, HDD and wireless card. We tried to locate the motherboard battery and replace it, but we couldn't do it since it is ...dunno the english word for it, but it is irreplaceable :D so we haven't touched it. We put all back together and started the laptop, but there was another error. Black screen and something like: resource conflict - PCI network controller something not working, in slot 06, something like that. And F1 to resume, F2 to setup. I tried pressing F1 and F2, but it didnt work, since my keyboard didn't work from before.
Could it be that my motherboard is dying? :(
__________________
tekun is offline   Reply With Quote
Old 01-20-2012, 09:45 AM   #6
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 53,865
OS: win 7 pro/ultimate/xp vm



Hi here is the service manual for the 5100 Acer Aspire 5100 Service Manual Removal Disassembly
I wonder if your network controller or wifi has gone south
__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline   Reply With Quote
Old 01-21-2012, 03:36 AM   #7
Registered Member
 
Join Date: Jan 2012
Posts: 4
OS: winXP sp3



yeah, im pretty sure that we didnt reconnect wireless card properly. I'll open my laptop again and disconnect it, and then try turning it on. It should boot normally, I assume :D Then ill try with portable linux :D
Of course, I could simply take laptop to a technician, but that would be too simple :D

I'll keep you posted.
__________________
tekun is offline   Reply With Quote
Old 05-19-2012, 05:21 PM   #8
Registered Member
 
Join Date: May 2012
Posts: 4
OS: windows 7



I know this is overly simplistic but hasn't been mentioned yet and might have good results, but have you tried plugging in an external keyboard and external mouse to your laptop?
This might be the "keys locked in the car for hours, but passenger door is unlocked" solution to the problem, until you can reload the drivers for the mouse and keyboard.

__________________
evath is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mouse and keyboard not working at welcome screen?
Hi. Whenever I'm starting up my computer, my keyboard and mouse stop working at the welcome screen. I've been having to hard-boot (is this bad since it's from the welcome screen?) because I can't manually turn off the computer, and then physically turn the computer back on and open system recovery...
Muskz Motherboards, Bios & CPU 21 08-19-2012 10:25 PM
HELP! Mouse & Keyboard randomly stop working
Help! I have TRIED to solve this myself, but now I'm considering giving up and getting a new computer. I thought I'd try my luck here first. I will give as much information as possible, so PLEASE bear with me... Starting about a month ago, my wireless mouse and keyboard would randomly stop...
jackieck Motherboards, Bios & CPU 10 12-17-2011 09:25 AM
Mouse and keyboard stop working after a while.
Hi sorry if this is in the wrong part of the forums. Today I got a gaming pc built to the specs I wanted, everything was working fine, then suddenly the mouse and keyboard stopped working - nothing had frozen i was still receiving messages through steam but i couldn't respond. I was using a...
wizzymeg Other Hardware Support 3 07-19-2011 09:17 AM
[SOLVED] keyboard and mouse not working
i haven't run across this before...first the keyboard wasn't working, i found it unplugged (not sure how THAT happened); plugged it back in and it still doesn't work. the mouse WAS working, but after i unplugged it (i was looking at the male end to make sure i was plugging the keyboard in right)...
jillocity Other Hardware Support 3 04-12-2011 08:10 PM
PS/2 Keyboard Not Working
So, I have a tendency to hit several keys on my keyboard, especially since I play using both hands on the keyboard in some scenarios... With the breaking of my USB keyboard (Ideazon Zboard, or SteelSeries Zboard), I decided to get a more durable keyboard operating on the PS/2 port rather than...
moltendorf Motherboards, Bios & CPU 1 02-11-2011 06:13 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 01:07 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts