Go Back   Tech Support Forum > Hardware Support > Laptop Support

Dell Laptop thinks battery is dead - but battery is working fine

This is a discussion on Dell Laptop thinks battery is dead - but battery is working fine within the Laptop Support forums, part of the Tech Support Forum category. I have a Dell Latitude D620. I recently installed a new hard drive, and with it a new version of


Closed Thread
 
Thread Tools Search this Thread
Old 12-03-2009, 09:15 PM   #1
Registered Member
 
Join Date: Oct 2009
Posts: 9
OS: Windows XP SP3



I have a Dell Latitude D620. I recently installed a new hard drive, and with it a new version of XP. At the time, the battery in my laptop was dead (e.g. unplug it and it shuts off in 5 seconds).

A few days later I got a brand new battery. However, my computer will not stop giving me the same messages about my battery being about to die. When I start up my computer, I get a message. Whenever I unplug it from the wall, I get a pop up screen telling me its about to die. Most annoyling, If i'm using it without the cord, windows after about an hour will shut down because it says my battery is dead. When I start it back up, it will last for another hour hour on the battery just fine. The battery indicator in the toolbar is fine - it will tell me I have about 2 hours fully charged.

Not sure what to do at this point. I have tried running my battery down to when it actually dies, but i'm still getting the messages.

Any help would be greatly appreciated. Thanks!

__________________
JPA077 is offline  
Old 12-04-2009, 07:09 AM   #2
TSF Enthusiast
 
Join Date: Aug 2006
Posts: 601
OS: Windows 7 x64



did you get this battery from Dell, or from a third party.

__________________
auntiej is offline  
Old 12-04-2009, 08:13 PM   #3
Registered Member
 
Join Date: Dec 2009
Location: Vancouver, WA
Posts: 17
OS: Vista


Send a message via Yahoo to drivenjesus

Try going into the Start Menu/Control Panels and Power settings and turn off the messages on 10%power etc?
__________________
drivenjesus is offline  
Old 12-04-2009, 10:53 PM   #4
Registered Member
 
Join Date: Oct 2009
Posts: 9
OS: Windows XP SP3



The battery is a dell battery bought from Dell. In fact, dell replaced my old dell battery with this one.
__________________
JPA077 is offline  
Old 12-05-2009, 06:01 AM   #5
TSF Enthusiast
 
Join Date: Aug 2006
Posts: 601
OS: Windows 7 x64



tbh as this is a new dell battery I would be inclined to get back to them and explain the problem, as it must be under guarantee.
__________________
auntiej is offline  
Old 12-22-2009, 12:18 PM   #6
Registered Member
 
Join Date: Dec 2009
Location: San Jose, Ca
Posts: 4
OS: XP



I guess that you need to update the Bios because old Bios not communicate with your laptop battery well

__________________
ask-techie is offline  
Closed Thread
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 04:44 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts