Go Back   Tech Support Forum > Hardware Support > Laptop Support

Acer Aspire Laptop screen flashes and turns black

This is a discussion on Acer Aspire Laptop screen flashes and turns black within the Laptop Support forums, part of the Tech Support Forum category. Hi It started a couple of weeks ago when I was playing Stalker, my screen would blink and go black


Closed Thread
 
Thread Tools Search this Thread
Old 09-24-2009, 03:40 AM   #1
Registered Member
 
Join Date: Jun 2009
Location: London
Posts: 11
OS: xp



Hi
It started a couple of weeks ago when I was playing Stalker, my screen would blink and go black for a minute or so, and then come back to normal. It would happen 1-2 times a day, and I though that my laptop simply couldn't handle the graphics and stop playing.
However, it then came back and got worse. Now the screen will blinck and go black (competely black) during normal usage or when it is idle(no, it is not going to sleep), it happend also during Windows XP loading and on Welcome screen. Sometimes it will happen after a minute and sometimes in an hour, also it may stay black for a minute, 5 or an hour, I can hear all thesounds and laptop cleary responds to my commands, so it is only the screen. There is no particular pattern on when and for howlong the black outs happen.
Any ideas, can it be software problem?

__________________
dimasafr is offline  
Old 09-24-2009, 08:17 AM   #2
TSF Enthusiast
 
night_shift's Avatar
 
Join Date: Sep 2009
Location: Scotland
Posts: 1,307
OS: Win8.1~Win7~Ubuntu



Give the bottom of the screen surround a firm but gentle tap when the screen goes black and see if recovers. If not read this -

http://reviews.ebay.co.uk/LAPTOP-MON...:-1:LISTINGS:1

__________________
night_shift is offline  
Old 09-25-2009, 12:45 AM   #3
Registered Member
 
Join Date: Jun 2009
Location: London
Posts: 11
OS: xp



Hi night_shift, no it didn't solve it, I have read that post and others over the net, most of them point at inverter board of backlight, however, my screen is either completely and I mean completely black - as no faded image on the background (however, there is slight blinking) , or when it works it works in full colours.
Also I couldn't book it in safe mode yesterday, it may or may not be related to the screen though.
__________________
dimasafr is offline  
Old 09-25-2009, 05:42 AM   #4
TSF Enthusiast
 
night_shift's Avatar
 
Join Date: Sep 2009
Location: Scotland
Posts: 1,307
OS: Win8.1~Win7~Ubuntu



Have you tried using an external monitor? If you can see your working desktop on the other monitor this should prove that ur graphics chip set is ok.

Im assuming when u said u have read the other posts that u have checked the basics like bad connections etc, blah,blah.....blah!

1. Try the external monitor. If ok then back to screen problems.
2. If desktop not showing on external monitor. Then could be a graphics chip, mobo or bios problem.
3. Start with the basics, remove any dust etc from cooling path. It might be a simple heating problem. Reseat all your RAM. If u got dedicated graphics make sure the heat sink is not loose, tightened down any loose screws. Some ATI chipsets give problems. Let me know what graphics you got. When u start up the system give the graphic chip a gentle push and see what happens.
4. If it still dont work u could try resetting the BIOS or update.
5. Next move would be to open up the case and look for bad solder joints and damaged components.
Have u carried out any major driver, Windows, software or hardware updates prior to this?
__________________
night_shift is offline  
Old 09-28-2009, 12:42 AM   #5
Registered Member
 
Join Date: Jun 2009
Location: London
Posts: 11
OS: xp



Yep, I will need to get hold of external monitor, didn't have a chance yet. I have read that it might be a driver problem, so I run system restore, it was forking fine for 2 hours, i'm not sure if it solved it or I just was lucky, will do more testing tonight and post on it.
__________________
dimasafr is offline  
Old 09-28-2009, 09:13 PM   #6
Registered Member
 
Join Date: Sep 2009
Posts: 1
OS: vista



I have had the same problem with my aspire and they also seem to overheat HORRIBLY. Luckily mine was only 4 months old when it totally died and so I sent it back and it had a load of bits replaced - motherboard and memory among others I believe, although I'm no expert and they don't actually tell you. My mothers aspire then developed the same fault and - again - was repaired under warranty. With a week left to go on my warranty mine has now died again!!! Its currently still in for repair, which, incidentally, has taken several weeks so far this time and was 6 weeks initially!! - my mothers took 10 days. Acers service is horrible and communication tends to be awful. They dont tell you what the fault was or what they've done to mend it. I had bought extra memory with mine and when they repaired it they removed that and it took me several months to even get a reply about that issue, and the memory still hasnt been replaced!! I'll never buy acer again to be honest, and I dont hold out much hope that this one will last very long when it eventually returns, judging on performance to date. I really hope you have better luck with them than I've had.
__________________
mumm is offline  
Old 09-29-2009, 01:55 PM   #7
TSF Enthusiast
 
night_shift's Avatar
 
Join Date: Sep 2009
Location: Scotland
Posts: 1,307
OS: Win8.1~Win7~Ubuntu



This is for mumm, if you hate ACER read this post. It started April 2007 and ended June this year.

http://www.ozzu.com/hardware/acer-la...rt-t76457.html
__________________
night_shift is offline  
Old 09-30-2009, 12:38 AM   #8
Registered Member
 
Join Date: Jun 2009
Location: London
Posts: 11
OS: xp



Ok last nightit worked fine, so I guess after all it was a driver problem and system restore sorted it out, it seems that buged video game screwed the video driver. However, I am still not 100% sure, will try to run something video intencive tonight and see if it handles it.
__________________
dimasafr is offline  
Old 10-01-2009, 08:37 AM   #9
TSF Enthusiast
 
night_shift's Avatar
 
Join Date: Sep 2009
Location: Scotland
Posts: 1,307
OS: Win8.1~Win7~Ubuntu



Thats good news. Long may it continue. If not post back.

__________________
night_shift is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:12 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts