Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

Windows XP, WMP 9, MTP porting kit, MP3 PLAYER PLAYLIST PROBLEMS!

This is a discussion on Windows XP, WMP 9, MTP porting kit, MP3 PLAYER PLAYLIST PROBLEMS! within the Windows XP Support forums, part of the Tech Support Forum category. Okay first let me say that i'm not this sure if this is the right location for posting this but


Closed Thread
 
Thread Tools Search this Thread
Old 07-11-2011, 02:36 PM   #1
Registered Member
 
Join Date: Dec 2008
Location: Northwest
Posts: 54
OS: Windows XP Home Edition, Service Pack 3


Evil

Okay first let me say that i'm not this sure if this is the right location for posting this but ima give it a try anyways...
Second let me say that ihave been trying to solve this issue for about the last 3 or so weeks over at
anythingbutipod.com and still have had no luck, i have in general been trying to get my mp3 player
to work for about three months since i originally got it, and of course still have had no luck

Here is the situation:
I bought a 8gb Sony nwz-e354 and after probably a month of putting all the music back on and what not due to my old mp3 crashing, i did the first thing i always due, which is create a playlist.... Well it turns out normally there are two ways only to make a playlist use WMP 10 or above i believe or use the Sony content transfer software or w/e it's called.

I won't use anything besides WMP 9 i really don't care what ppl say about it, or how old it is.
WMP 9 just simply has the only layout i like, i like the tab's on the side running vertically (i mean like the media library, now playing, media guide, etc...) I hate them running across the top like all the versions after 9 have.

Anywho the reason one must use WMP 10+ or Sony software is because both of those items install the MTP driver's into ur system necessary for the mp3 player to be detected as a... well mp3 player.Without the MTP drivers it will still install but it only installs as a mass storage device. Granted u can still transfer music however, u cannot create playlist.Getting it to install in general was a challenge when i selected install automatically, it couldn't install, i had to push install manually, than select the type of device and actually click "mass storage device" then let it install. Also manually installing and trying to select MTP device does not work either.

So i tried to just keep it a mass storage device and use other programs that ppl who have this mp3 were saying are really good. I tried Media Monkey which nearly works for everything, and i tried Winamp (both the newest versions) and neither worked. Well i shouldn't say that i could initially see the music on the player and the select the song's i wanted and then create a playlist but the playlist in both program's can only output .m3u playlist. And apparently the playlist format that the sony reads is ".pla"

So the next step i tried was creating playlist in both programs again, and than using a program i found that convert's m3u playlist to .pla, well it worked and i got a properly formatted playlist but when i put it in the playlist folder, still no luck. SOOO... i took the next step and found a script that you could add to media monkey to give it the option to output .pla playlist I created a playlist (sigh.. again...) and outputted it with a .pla format, stuck it in the playlist folder and again no luck....

So i sat and thought for a sec about what could be wrong and i just couldn't figure it out, also my playlist is only about 180 songs, so it really ain't that big at all. Finally after about a month of so of these petty games i got the answer that it was because the player needed the MTP drivers to properly be recognized. Once that is all in line u can create a playlist in media monkey, winamp, u apparently can do it with just explorer via right click menu....

So i tried to find the actual MTP driver's online somewhere but that a total freakin joke. Eventually i stumbled upon the MTP porting kit from microsoft which apparently installs the drivers u need without having to get WMP 10+ i was about to explode from excitement....

So when i finally got it, i installed it, and then uninstalled the drivers for the mp3 player that were installed under the parameters of it being a mass storage device. Then i plugged it back in and waited for the little "found new hardware" window to pop up, once it did i pushed install automatically (so it would in turn be installing as a MTP device) HOWEVER.... IT DID THE SAME THING!!!!

I was furious, but i figured maybe it doesn't if it installs like that, because after all the MTP porting kit is installed. So i tried in Media monkey and Winamp again to create playlist, and both of them i had no luck with.

So at this point i was looking for a axe to destroy the mp3 player with, but i eventually calmed down and read the little read-me thing that installed with the rest of the stuff in the MTP porting kit folder.
and what it said well here let me quote it...
[I]"Operating system
Recommendation: Microsoft Windows XP Professional Service Pack 2 (SP2) or Windows Vista with Windows Media Player 11." [I]

Okay hmmm.. that's odd it look's almost like it say's it only need's WMP 11 if u have vista.... How peculiar, cuz i have XP with SP3. Now why don't we look at the read-me for the way to actually install the MTP driver's.

How can my device be detected as an MTP device?
Windows detects devices as MTP class devices using three methods. For Windows XP and Windows Vista, you should use the OS Descriptor as described in the Portable Devices Installation Guidelines document (provided in the \Documents folder). For Windows Vista, you may also use the former PTP USB Still Image device class (Class 6, Subclass 1, Protocol 1).

For devices that cannot support the USB Class ID or the OS Descriptor, a custom .INF file should be used. For systems with Windows Media Player 10, you should customize the .INF file supplied in the \Redist directory. For systems using Windows Media Player 11 for Windows XP or Windows Vista, you should use a customized version of the .inf located here:c:\windows\inf\WPDMTPHW.INF.


WOW!!! that is just the darndest thing now isn't, i didnt see a single mention of anything other then WMP 10+..... See this is what i dont understand why would you install this crap if u already had WMP 10+ seeing as version's 10 and above all come with the MTP drivers actually as part of their build. THE REASON I GOT THIS TOOL IS SO I WOULDN'T NEED A DIFF. DARN VERSION OF WMP!!!!!!!!!!!!!!!!!!!!!!!!!!!

Please excuse me but i dont think i have word's that can actually express how pissed off, frustrated, annoyed, disappointed, and confused this has all made me. I just want to listen to my music i dont understand why that has to be so complicated.

Now what it all boil's down to really other than not wanting a different looking version of WMP, is the actual way that playlist are created if one uses WMP or the sony software. Now ya see the thing i always have noticed about playlist is that they are very small sized file's that are in reality just text file's in special format. The keyword's there were "small sized" keep that in mind.

When one use's WMP or the sony software what occurs with playlist creation is that for each and every song on ur playlist, another copy pretty much of that song is created. It's hard to explain but for example i will use a few songs off my playlist to show what i mean better.
Let's say on my playlist i have the songs:
SONG: ARTIST:
Eternal Gates Of Hell Dead To Fall
Antichrist Superstar Marilyn Manson
Lines of Suicide The Agony Scene

Now when the playlist get's created and it's all finished what my folder layout would look something like this,
(By the way every song on my player has the exact same folder layout - i have a folder with the artist name on it, within that folder i have folder's with the name's of the album followed by a space, a hyphen, another space, then the year of album, then within those folders i have the songs themselves just fyi)

These below are how it looked BEFORE the playlist:
Dead To Fall
Everything I Touch Falls To Pieces - 2002
Eternal Gates Of Hell

Marilyn Manson
Antichrist Superstar - 1996
Antichrist Superstar

The Agony Scene
The Agony Scene - 2003
Lines Of Suicide

Now AFTER the playlist is created i would have a layout somewhat like this:
Dead To Fall
Everything I Touch Falls To Pieces
Eternal Gates Of Hell
Everything I Touch Falls To Pieces - 2002
Eternal Gates Of Hell

Marilyn Manson
Antichrist Superstar
Antichrist Superstar
Antichrist Superstar - 1996
Antichrist Superstar

The Agony Scene
The Agony Scene
Lines Of Suicide
The Agony Scene - 2003
Lines Of Suicide

As you can clearly see a new album folder is created (the one without the date obviously). Now if the problem with this isn't so obvious a blind person could see it, i tell my issue with it. What the hell is the point of creating a playlist (remember the keyword's earlier "small sized") if you end up with another copy of every song on ur playlist, that has to be the most ridiculous thing i have ever heard.

Now just before i continue anymore i will first apologize for the length of this thread but i am just trying to be as thorough as possible and give as much info as i can because i really really really want this to be fixed.
Secondly i have a few things only that under no circumstances despite any plausible situation I WILL NOT DO:
1.) Install a diff copy of WMP
2.) Install the sony software
3.) Install a diff OS

Other than that i am willing and have been trying everything. My real question here was such...
I was wondering if u guy's anyone on here really, could somehow tweak the files installed by the MTP porting kit so that it will comply with WMP 9 or maybe send me drivers or some file that will install MTP drivers on my system. Which if u haven't already figured it is XP SP3 with WMP 9.

I know someone can fix this, imo i always tell ppl that the user's on this site like the mod's and admin's and ppl that help ppl like me, are so smart they make the ppl that wrote the actual Microsoft OS look like idiots lol. This also is why i said i'm not sure if posted this in the right spot, but if i didn't could someone point me towards the right way. All i want to do is listen to my music, i havent been able to use my mp3 player now since i got it cuz of this, and that was 3 months ago.

So PLEASE someone help me i am at my wit's end with this i have no where else to turn but the expert's i.e. u guys.
[B][I]Also just as an fyi here is the link of my thread on anythingbutipod.com forum where i'm
discussing this same thing, just in case u wanna get a better idea of what i have already tried.
Help with freaking e345 playlist!!! - Walkman E Series - abi>>forums

Thanks for all you guy's help.

__________________
theomega76 is offline  
Old 07-11-2011, 03:08 PM   #2
Registered Member
 
Join Date: Dec 2008
Location: Northwest
Posts: 54
OS: Windows XP Home Edition, Service Pack 3



Sorry here is a better idea of how my folder layout look's, i didn't realize my post would mess up the formatting of how i had it, (and no i don't actually have the little < or > sign's i'm just doin that for demonstrative purposes)

These below are how it looked BEFORE the playlist:
<ARTIST> Dead To Fall
<ALBUM> Everything I Touch Falls To Pieces – 2002
<SONG> Eternal Gates Of Hell

<ARTIST> Marilyn Manson
<ALBUM> Antichrist Superstar – 1996
<SONG> Antichrist Superstar

<ARTIST> The Agony Scene
<ALBUM> The Agony Scene – 2003
<SONG> Lines Of Suicide

Now AFTER the playlist is created i would have a layout somewhat like this:
<ARTIST> Dead To Fall
<ALBUM> Everything I Touch Falls To Pieces
<SONG> Eternal Gates Of Hell
<ALBUM> Everything I Touch Falls To Pieces – 2002
<SONG> Eternal Gates Of Hell

<ARTIST> Marilyn Manson
<ALBUM> Antichrist Superstar
<SONG> Antichrist Superstar
<ALBUM> Antichrist Superstar – 1996
<SONG> Antichrist Superstar

<ARTIST> The Agony Scene
<ALBUM> The Agony Scene
<SONG> Lines Of Suicide
<ALBUM> The Agony Scene – 2003
<SONG> Lines Of Suicide

__________________
theomega76 is offline  
Old 07-12-2011, 01:14 PM   #3
Registered Member
 
Join Date: Dec 2008
Location: Northwest
Posts: 54
OS: Windows XP Home Edition, Service Pack 3



i know i cant bump this yet but i mean seriously has anyone even glanced at this, i am really really desperate
__________________
theomega76 is offline  
Old 07-13-2011, 01:22 AM   #4
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 28,625
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


ummm why can't you just drag and drop your music files onto the Sony device from your Music folder? Or from WiMP9?
spunk.funk is offline  
Old 07-16-2011, 05:37 PM   #5
Registered Member
 
Join Date: Dec 2008
Location: Northwest
Posts: 54
OS: Windows XP Home Edition, Service Pack 3



i can drag and drop onto it, i have it like 5 gigs of music on there already but my entire like 3 page post was literally only about wanting to know why microsoft wont let you have any form of MTP drivers on WMP 9 at all. i rater burn in the deepest fires of hell the install another version of WMP... it makes no sense to me..

And i know for a fact that somewhere on this site that one of u guys is smart enough to know how to tweak the actual data files for the MTP porting kit to make it compatible with WMP 9 or make something to allow WMP 9 to accept the drivers somehow, i have faith in u guys :)

__________________
theomega76 is offline  
Closed Thread
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
.exe problems, and possible Malware issues
Aloha, Need help... not sure what to do, hopefully I posted this correctly this time! Mahalo, Red Eye . DDS (Ver_2011-06-03.01) - NTFSx86 Internet Explorer: 8.0.6001.18702 BrowserJavaVersion: 1.6.0_24 Run by Jennifer at 14:07:36 on 2011-06-09
RED EYE TRUKIN Resolved HJT Threads 10 06-28-2011 07:27 AM
Check-up please
Hi All, There are no specific problems with my computer, but if I could have a check-up for peace of mind then that would be greatly appreciated. Below and attached are the log files as requested . DDS (Ver_2011-06-12.02) - NTFSx86 Internet Explorer: 6.0.2900.5512 BrowserJavaVersion:...
ben1390 Resolved HJT Threads 5 06-22-2011 08:40 PM
stepped in it ..Again :{
I clicked on a photo yesterday on a google search results screen when a notice popped up saying that there was a potential virus, initially I thought it was a waring from my Verizon Security Suite, so I clicked on Quarenteen...in hind sight, I think this warning was somthing different. Now, my...
scotlb Resolved HJT Threads 14 01-23-2011 08:47 PM
Random popups and site redirecting virus
Hello, I'm new to the forum and my problem is that I'm being redirected to unwanted sites like Tazinga or Binkx. I'm running Windows XP and my laptop is about 7 years old. Any help would be great! Here are the Hijack specc UNLESS SPECIFICALLY INSTRUCTED, DO NOT POST THIS LOG. IF REQUESTED,...
Hexamus Inactive Malware Help Topics 2 01-11-2011 08:15 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:58 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts