Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

windows update and update.inf

This is a discussion on windows update and update.inf within the Windows XP Support forums, part of the Tech Support Forum category. I went to windows update to download the latest updates, but I keep getting the error message "Setup could not


Closed Thread
 
Thread Tools Search this Thread
Old 07-05-2007, 12:08 PM   #1
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



I went to windows update to download the latest updates, but I keep getting the error message "Setup could not verify the integrity of the file Update.inf. Make sure the Crytographic service is running on this computer." The Cryptographic service is running as I checked numerous times. I also followed all the steps to fixing this problem on the microsoft support page ( http://support.microsoft.com/kb/822798 ) but there is still no luck. Next, I ran a search for the update.inf file and I don't think I have the file. Is there anyway to fix this problem? If it's because of the missing Update.inf file, is there anyway to recover it? Any help is appreciated. Thank You.

-Justin

__________________
anonangyari is offline  
Old 07-05-2007, 12:11 PM   #2
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



Hi and welcome,
If you have your windows xp disk click start, run, type cmd, type sfc /scannow. If it needs your disk it will tell you to insert it.

__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 01:04 PM   #3
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



Thanks Kinbard. I did exactly that, ran the "sfc /scannow" command just like you said. It didn't need the disk, but after the scan finished, nothing happened afterwards. Any Suggestions?
__________________
anonangyari is offline  
Old 07-05-2007, 01:07 PM   #4
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



When you did the search did you tell it to check hidden files and folders? Also, do you have any third party themes installed, like window blinds?
__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 01:17 PM   #5
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



Update.inf should be in c:\windows\softwaredistribution\download
In there you will probably see more than one folder with a bunch of letters and numbers with names. It will be in one of those, usually the first. Are you running service pack 2 on you xp installation, or 1?
__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 01:40 PM   #6
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



Yup, I checked the "hidden files and folders" box. But it still did not find the update.inf file. And I just checked the theme of the computer, and no, no third party themes are installed. Sorry for the trouble Kinbard.
__________________
anonangyari is offline  
Old 07-05-2007, 01:45 PM   #7
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



No trouble at all. Right click you my computer icon. Up at the top where it says Microsoft Windows XP does it say service pack 1 or 2? From what I have seen researching this it is a big problem in service pack 1.
__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 01:59 PM   #8
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



Service pack 2
__________________
anonangyari is offline  
Old 07-05-2007, 02:03 PM   #9
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



Ok, first set a system restore point. Click start, all programs, accessories, system tools, system restore. Follow the directions it gives you.

Once that is finished click start, run, type cmd. Type the following, one line at a time, hitting enter between each:
net stop cryptsvc
ren %systemroot%\system32\catroot2 oldcatroot2
net start cryptsvc

See if that helps any.
__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 02:14 PM   #10
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



I did all that before I posted this thread, just like it said on the windows support website. I even manually renamed the catroot2 folder to oldcatroot2. But there was still no luck =[
__________________
anonangyari is offline  
Old 07-05-2007, 02:21 PM   #11
TSF Team Emeritus
 
Chevy's Avatar
 
Join Date: Jul 2003
Location: Notlob
Posts: 5,441
OS: Vista Ultimate

My System


Try reapplying Service Pack 2.

you can download the full install HERE. Just download it, then run it.

Sometimes reapplying the latest SP manually does the job.
__________________
Chevy is offline  
Old 07-05-2007, 02:25 PM   #12
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



Quote:
Originally Posted by anonangyari View Post
I did all that before I posted this thread, just like it said on the windows support website. I even manually renamed the catroot2 folder to oldcatroot2. But there was still no luck =[
Sorry, I didn't read all the link to Microsoft, so I didn't see it in there (It bored me)
Give Chevys advice a go. I thought about that, but wasn't sure if the problem would extend to that as well.
__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Old 07-05-2007, 05:09 PM   #13
Registered Member
 
Join Date: Jul 2007
Posts: 8
OS: xp



Oh man an hour download and it still didn't work =[
Well since the service pack just got re-installed, I'm going to retry everything on the microsoft support webpage again. I'll post back if nothing changes. Thanks Kinbard and Chevy
__________________
anonangyari is offline  
Old 03-28-2009, 03:22 PM   #14
Registered Member
 
Join Date: Jan 2009
Posts: 12
OS: XP Pro SP2



Quote:
Originally Posted by kinbard View Post
Update.inf should be in c:\windows\softwaredistribution\download
In there you will probably see more than one folder with a bunch of letters and numbers with names. It will be in one of those, usually the first. Are you running service pack 2 on you xp installation, or 1?
I have been having the same problem. I just checked for update.inf. I have only updateBR.inf. I am running WinSP Pro SP2. If I reinstall SP2 won't the result be 2 files? One Update.inf and one updateBR.inf. Should I renameupdateBR.inf? Then re-install? mackey1
__________________
mackey1 is offline  
Old 03-28-2009, 08:10 PM   #15
TSF Enthusiast
 
kinbard's Avatar
 
Join Date: Jun 2006
Location: Texas
Posts: 3,459
OS: Experimenter



This is a pretty old thread. Start your own, and we will go from there. You can PM me with the link.

__________________
Half viking, half pirate, stronger than both
XP Repair
Malware Removal
Vista Repair
Downgrade Vista
kinbard is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ultimate defender
I keep getting popups from various sites that want me to install their removal software. Ultimate defender, ultimate cleaner 2007. I am also getting a dating service and personal ads directory pop up. Here is my HJT log Logfile of HijackThis v1.99.1 Scan saved at 12:26:06 PM, on 1/21/2007...
Gaijin Inactive Malware Help Topics 8 01-30-2007 07:58 PM
Multiple issues,Update, Web Hijack,trojans HJT analyzer
I have many problems. I cannot update windows either via web or downloaded sp1a. Cryptographic service error reported it is enabled in services when online scanners are run housecall results do not show up to select action. When some websites are typed in I get % signs, popups when ewido is run...
jabear Inactive Malware Help Topics 16 09-16-2005 07:24 AM
Update.inf
When I boot up my system, I get a window thats "Setup could not find the update.inf file needed to update your system." Is there a way I can download update.inf (which I haven't been able to do)? How can I fix this?
thad_rad Windows XP Support 2 03-06-2005 10:08 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:22 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts