Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

[SOLVED] USB Key-Disks not showing up under Explorer - SP2 / patch problem?

This is a discussion on [SOLVED] USB Key-Disks not showing up under Explorer - SP2 / patch problem? within the Windows XP Support forums, part of the Tech Support Forum category. I have three USB key disks, two from Disgo and one from Integral. They were working under SP2 until a


Closed Thread
 
Thread Tools Search this Thread
Old 03-01-2005, 02:40 AM   #1
Registered Member
 
Join Date: Feb 2005
Location: UK, NorthWest
Posts: 38
OS: WinXP



I have three USB key disks, two from Disgo and one from Integral.
They were working under SP2 until a host of fixes came in through Windows Update.

My home and work PC's have the same level of patching and none of the 3 USB disks now work on *either* system.

Does anyone know of an issue with any of the fixes that would have been installed?

Thanks,
Dave

__________________
horrgakx is offline  
Old 03-01-2005, 06:17 AM   #2
Registered Member
 
Join Date: Oct 2004
Location: Long Island, NY
Posts: 405
OS: XP Pro SP2

My System

You might try inserting a USB key and then checking Disk Management (right click My Computer, left click Manage, left click Disk Management). See if the key shows up there and if possibly Windows is assigning a drive letter that's already in use by another device or network drive. If so, you can change the drive letter for the key from within Disk Management by right clicking on the drive and following the prompts.

__________________
ksteiger is offline  
Old 03-01-2005, 07:45 AM   #3
Registered Member
 
Join Date: Feb 2005
Location: UK, NorthWest
Posts: 38
OS: WinXP


It is really bizarre.

I managed to get to the data by opening the Disk Management console, right-clicking and choosing "Open".
If I choose "Explore" it does not show up.
Also if I "Open" and then put the folder view on the drive disappears from the list.

Dave
__________________
horrgakx is offline  
Old 03-01-2005, 08:13 AM   #4
Registered Member
 
Join Date: Oct 2004
Location: Long Island, NY
Posts: 405
OS: XP Pro SP2

My System

Is XP assigning it a drive letter? And is that letter a conflict with another device in your system, such as a CD-ROM?
__________________
ksteiger is offline  
Old 03-01-2005, 08:21 AM   #5
Registered Member
 
Join Date: Feb 2005
Location: UK, NorthWest
Posts: 38
OS: WinXP


Yep - last physical drive D:, 1st network drive K:. XP is assigning it as E: but I also changed it to F: and same result.
__________________
horrgakx is offline  
Old 03-01-2005, 09:26 AM   #6
Registered Member
 
Join Date: Oct 2004
Location: Long Island, NY
Posts: 405
OS: XP Pro SP2

My System

Sorry, Dave, I've run out of ideas. I was hoping there was a conflict with a mapped network drive since that's a very common problem with USB key disks. Maybe someone else has an idea, but I'm fresh out. Good luck.
__________________
ksteiger is offline  
Old 03-01-2005, 11:13 AM   #7
Microsoft MVP
 
johnwill's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2002
Location: S.E. Pennsylvania, US
Posts: 50,845
OS: Windows 7, XP-Pro, Vista, Linux

My System

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
__________________
If TSF has helped you, Tell us about it! or Donate to help keep the site up!

Microsoft MVP - Windows Desktop Experience
johnwill is offline  
Old 03-02-2005, 01:32 AM   #8
Registered Member
 
Join Date: Feb 2005
Location: UK, NorthWest
Posts: 38
OS: WinXP


Johnwill, thanks for that, I followed your instructions and all 3 USB key-disks are now working!!!

Can you tell me what caused that problem then?

Thanks,
Dave
__________________
horrgakx is offline  
Old 03-02-2005, 10:14 AM   #9
Microsoft MVP
 
johnwill's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2002
Location: S.E. Pennsylvania, US
Posts: 50,845
OS: Windows 7, XP-Pro, Vista, Linux

My System

Glad we got you going. To be truthful, it's somewhat difficult to know exactly how things get hosed. What happens is that a driver that is incorrectly configured for the disk in question gets loaded, and it blocks the proper driver. By removing all the references, you clean out the pool, and allow a fresh configuration.

This happens more than you might imagine.
__________________
If TSF has helped you, Tell us about it! or Donate to help keep the site up!

Microsoft MVP - Windows Desktop Experience
johnwill is offline  
Old 01-20-2008, 12:23 PM   #10
cherokee1111
Guest
 
Posts: n/a
OS:



hi there, sorry to jump on thread, but I have exactly the same issue I think, except the pc makes the DUH! DAH! noise when I put a usb in and I see it under usb controllers as mass storage device, but for the life of me I cant see it in My computer.

Tried the uninstall process twice but no luck, any ideas guys?

thanks
__________________
 
Old 01-20-2008, 12:59 PM   #11
Registered Member
 
Join Date: Oct 2004
Location: Long Island, NY
Posts: 405
OS: XP Pro SP2

My System


You may have a drive letter conflict. Right click on My Computer, left click on Manage, then click on Disk Management and see if you can find your USB thumb drive. If so, right click on it in the top pane and opt to change drive letter. Then assign it a drive letter that is not currently in use.
__________________
ksteiger is offline  
Old 01-21-2008, 03:01 AM   #12
cherokee1111
Guest
 
Posts: n/a
OS:



thanks, I'll try that tonight, fingers crossed
__________________
 
Old 01-21-2008, 03:17 AM   #13
Registered Member
 
Join Date: Jan 2008
Posts: 1
OS: windows xp home



i would try to uninstall everything under usb but there is no usb in the list. it just vanished. gone . no where to be found. what can i do. please help.
__________________
shadowman59 is offline  
Old 01-23-2008, 01:39 AM   #14
cherokee1111
Guest
 
Posts: n/a
OS:



Quote:
Originally Posted by ksteiger View Post
You may have a drive letter conflict. Right click on My Computer, left click on Manage, then click on Disk Management and see if you can find your USB thumb drive. If so, right click on it in the top pane and opt to change drive letter. Then assign it a drive letter that is not currently in use.

ok, disk management sees the usb mass storage device, I assign a letter and still cant see it in My Computer, pull out the key and the pc does the DAH! DAH! noise. SO, it sees it, it def has it in disk management, its def in safely remove hardware but I cant see the fooker anywhere to open it.

P.S if i put it in again and go to disc management it wants to assign another letter and the letter I already assigned isnt in the drop down anymore!!

help please, am I going MAD
__________________
 
Old 01-27-2008, 04:28 PM   #15
cherokee1111
Guest
 
Posts: n/a
OS:



anyone? :(
__________________
 
Old 01-28-2008, 04:37 PM   #16
cherokee1111
Guest
 
Posts: n/a
OS:



anyone??
__________________
 
Old 02-01-2008, 01:05 PM   #17
Registered Member
 
Mountainman1863's Avatar
 
Join Date: Dec 2007
Location: Syracuse
Posts: 79
OS: XP Pro SP2 (both machines)



Try looking at the removables using Windows Explorer, rather than just double-clicking on My Computer. Why there is a difference between the two, I do not know.
__________________
Mountainman1863 is offline  
Old 02-01-2008, 02:11 PM   #18
elf
TSF Team Emeritus
Microsoft Support
 
elf's Avatar
 
Join Date: Jul 2002
Location: Knoxville, TN or Austin, TX depending
Posts: 7,196
OS: WinXP Pro SP3 and Windows 7

My System

Send a message via AIM to elf

cherokee, this thread was resolved in 2005. Please start a new thread with your problem.
__________________

If TSF has helped you, Tell us about it! or Donate to help keep the site up!
I do not subscribe to threads, so if I stop replying, PM me with a link to your thread so I can find it again.
elf is offline  
Old 02-03-2008, 12:19 AM   #19
Registered Member
 
Join Date: Feb 2008
Location: Leduc, Alberta, Canada
Posts: 23
OS: win xp



Update ur windows security.. KB updates all of them....
__________________
dimpils666 is offline  
Old 02-03-2008, 02:09 AM   #20
cherokee1111
Guest
 
Posts: n/a
OS:



Quote:
Originally Posted by Mountainman1863 View Post
Try looking at the removables using Windows Explorer, rather than just double-clicking on My Computer. Why there is a difference between the two, I do not know.
there isnt and its not there eiether as that is a mirror of my comp, thanks anyway.


NEW thread started Elf, sorry

__________________
 
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:48 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts