Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

[SOLVED] Microsoft Update Fails to Install

This is a discussion on [SOLVED] Microsoft Update Fails to Install within the Windows XP Support forums, part of the Tech Support Forum category. Some Updates were not installed The following updates were not installed Installation Failure: Windows failed to install the following update


Closed Thread
 
Thread Tools Search this Thread
Old 06-05-2011, 08:21 AM   #1
Registered User
 
Join Date: May 2011
Posts: 360
OS: Windows 7



Quote:
Some Updates were not installed

The following updates were not installed

Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 2.0 Service Pack 2 Update for Windows Server 2003 and Windows XP x86 (KB976569).

Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.0 Service Pack 2 Update for Windows Server 2003 and Windows XP x86 (KB976570).

Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.5 SP1 Update for Windows Server 2003 and Windows XP x86 (KB982168).

Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.5 SP1 and .NET Framework 2.0 SP2 Security Update for Windows 2000, Windows Server 2003, and Windows XP x86 (KB979909).

Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.5 SP1 and .NET Framework 2.0 SP2 Update for Windows Server 2003 and Windows XP x86 (KB982524).

Installation Failure: Windows failed to install the following update with error 0x80070643: Security Update for Microsoft .NET Framework 2.0 SP2 and 3.5 SP1 on Windows Server 2003 and Windows XP x86 (KB2418241).

Installation Failure: Windows failed to install the following update with error 0x80070643: Security Update for Microsoft .NET Framework 3.5 SP1 on Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008 x86 (KB2416473).

Installation Failure: Windows failed to install the following update with error 0x80070643: Security Update for Microsoft .NET Framework 1.1 SP1 on Windows XP, Windows Vista, and Windows Server 2008 x86 (KB2416447).

Installation Failure: Windows failed to install the following update with error 0x80070643: Security Update for .NET Framework 2.0 SP2 and 3.5 SP1 on Windows Server 2003 and Windows XP x86 (KB2446704).
Note this are all .NET related. I don't know what that means. I've run every Windows Update repair tool I can think of. All other Windows Updates install normally, I assume this is .NET specific. I'm hoping to avoid having to manually uninstall all the .NET stuff. I did it a while back and remember it was pretty tedious.

Any help?

__________________
Proxyman is offline  
Old 06-05-2011, 10:32 AM   #2
Team Manager - Hardware
 
Rich-M's Avatar
 
Join Date: May 2007
Location: NE Pennsylvania
Posts: 7,529
OS: Windows 7 Professional

My System


I note these are all Net Framework Updates, did you ever install the originals which you can do from "Optional Software" at the Windows Update site?

__________________


All PC's are not the same. Posting your PC specs will help us to assist you quicker and effectively.
Rich-M is online now  
Old 06-05-2011, 10:48 AM   #3
Registered User
 
Join Date: May 2011
Posts: 360
OS: Windows 7



All of the above were done "Manually", by going directly to the MS website.
__________________
Proxyman is offline  
Old 06-05-2011, 11:18 AM   #4
Team Manager - Hardware
 
Rich-M's Avatar
 
Join Date: May 2007
Location: NE Pennsylvania
Posts: 7,529
OS: Windows 7 Professional

My System


Ok so you were able to install them, just not through Automatic Updates?
__________________


All PC's are not the same. Posting your PC specs will help us to assist you quicker and effectively.
Rich-M is online now  
Old 06-05-2011, 11:53 AM   #5
Registered User
 
Join Date: May 2011
Posts: 360
OS: Windows 7



Quote:
Originally Posted by Rich-M View Post
Ok so you were able to install them, just not through Automatic Updates?
No, they all failed many times (more than 5) both automatic and manual.
__________________
Proxyman is offline  
Old 06-05-2011, 12:26 PM   #6
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 27,677
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


download the dotnetfix cleanup tool. Uninstall all versions of .NET and restart the computer then download them all again in the proper order through Windows Update.
spunk.funk is offline  
Old 06-06-2011, 07:08 PM   #7
Registered User
 
Join Date: May 2011
Posts: 360
OS: Windows 7



Thanks spunk.funk for the suggestion. I had to run the tool several times before it did the trick. There was some weird problem with .NET 3.5. I'd run the tool, go to Windows Update, 3.5 would fail, I'd run the tool again, etc... Several iterations of this before I finally decided to stop running the "Uninstall All" option, and selectively pick only .NET 3.5.

Windows Update fully installed all the other .NET versions (including 4.0), then when I uninstalled 3.5 for the last time, and went to Windows Upate (yet again) it didn't even WANT to install 3.5. I'm wondering if I didn't have a duplicate install that needed to be uninstalled more than once, or if 4.0 supercedes 3.5 in some way making it unnecessary.

Posted all of that in case someone else is in the same situation. It failed the first 2 or 3 times, but I kept after it and eventually it wound up getting fixed. Not sure how, but at least it's fixed. Thanks again.
__________________
Proxyman is offline  
Old 06-06-2011, 08:30 PM   #8
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 27,677
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


You're Welcome. glad you got it sorted out.

spunk.funk is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
"XP Security 2011" Virus
I am having some serious problems. I believe I have some sort of virus. This XP SECURITY 2011 keeps popping up trying to make me buy their program. It seems to have disabled my Internet and also my task manager. Anyone have a solution here? Thanks in advance.
BigHock Windows XP Support 6 05-14-2011 12:23 PM
Spyware/malware issues
I am convinced that I have spyware/malware or something going on with my computer. I have ran several programs - malwarebytes, windows defender, and windows malicious software removal tools that say the computer is not infected. However, I am still having problems and some strange things have...
Ladysmith94 Resolved HJT Threads 31 04-22-2011 06:24 AM
Fake Windows Security Program has infected my computer! Please help me remove it!
i was simply browsing the web, and when I hit a link this Windows Security scanner program popped up with several different pop ups and tried telling me my computer was infected with all these particular files. I didn't subscribe to it or anything I just clicked out of it. Now, my computer...
flip25 Inactive Malware Help Topics 4 04-12-2011 11:23 AM
Malware
Hi, my laptop got hijacked. When I power my laptop it will bootup and then I will get a security alert that says, "Virus Alert! Application can't be started! The file mpcmdrun.exe is damaged. Do you want to activate your antivirus software now? If you press yes, then it will open Internet...
dv82u Resolved HJT Threads 14 03-18-2011 11:46 PM
Virus and Malware Removal
When opening programs or searching the internet, every activity always causes my memory usage to peak to 100%. It wouldn't bother me if it didn't slow things down. My computer used to perform better. I have a pentium 4, 1.8 ghz with 1gig of ram. Google maps is a particular problem, it uses so much...
NWAngler Resolved HJT Threads 9 03-14-2011 07:18 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 04:43 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts