Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

Print spooler service won't turn on

This is a discussion on Print spooler service won't turn on within the Windows XP Support forums, part of the Tech Support Forum category. hi... I am trying to reinstall my printer, but i can't as everytime i try, i get this message up


Closed Thread
 
Thread Tools Search this Thread
Old 01-05-2005, 09:58 AM   #1
Registered Member
 
Join Date: Jan 2005
Posts: 6
OS: WinXP


Pin

hi...

I am trying to reinstall my printer, but i can't as everytime i try, i get this message up @the print spooler service cannot be started on local computer'.

It also says that the RPC server is unavailable. I have tried to rectify these problems, but i am unable to turn on the print spooler!!

Help me, please...thanks, bmfenner

__________________
bmfenner is offline  
Old 01-05-2005, 12:12 PM   #2
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT


Hello bmfenner

Check in the Registry and check this key and see if it is blank:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler\\ImagePath

The value of the key should be:

%SystemRoot%\system32\spoolsv.exe


Or try and open services.msc is the the Run Command

Look for Print Spooler
Double click on it for its Properties.
Click the Startup type: set to Automatic
Click on Start.
if Start is grayed out.
then click on Stop. Then click on Start.

the path is C:\Windows\system32\spoolsv.exe

Check in that path if the spoolsv.exe if there,
if it is not you can copy it from another XP machine. Or from the C:\Windows\ServicePackFiles\i386 dircetory
or search for it on your PC




Let us know if this has helped.

__________________
Geekgirl is offline  
Old 01-05-2005, 01:00 PM   #3
Sgt.
 
Sarge's Avatar
 
Join Date: Nov 2004
Location: Earth
Posts: 657
OS: Windows 7 x64 Ultimate


Quote:
Originally Posted by bmfenner
hi...

I am trying to reinstall my printer, but i can't as everytime i try, i get this message up @the print spooler service cannot be started on local computer'.

It also says that the RPC server is unavailable. I have tried to rectify these problems, but i am unable to turn on the print spooler!!

Help me, please...thanks, bmfenner
Are you running XP home or XP pro?
Go Start>Settings>Control Panel>Administrative Tools>Services. In the "Services (local)" frame, find "Remote Procedure Call (RPC)" Double click on that item. Set it to "Automatic", and if it's stopped, try starting it.

Report results here.
__________________
Sarge is offline  
Old 01-06-2005, 03:12 AM   #4
Registered Member
 
Join Date: Jan 2005
Posts: 6
OS: WinXP



cheers, but i tried that and it wont work!any other suggestions??

Thanks, bmfenner

Quote:
Originally Posted by Sarge
Are you running XP home or XP pro?
Go Start>Settings>Control Panel>Administrative Tools>Services. In the "Services (local)" frame, find "Remote Procedure Call (RPC)" Double click on that item. Set it to "Automatic", and if it's stopped, try starting it.

Report results here.
Hi...im running XP home edition.

I tried to turn the RPC on, but the automatic box is greyed out, and so are all the start/stop etc buttons!!!

Not sure what to do now??

Thanks, bmfenner
__________________
bmfenner is offline  
Old 01-08-2005, 01:12 AM   #5
Registered Member
 
Join Date: Jan 2005
Posts: 4
OS: XP SP2


Hi! I don't know if this is of help but here goes!

When I couldn't print and it couldn't start the spooler service, I found I had a programme running in the background called NewDotNet (check in task manager). It downloads itself without you knowing from sites like Kazaa and Neonapster. As soon as I uninstalled it my printer worked perfectly again!!

__________________
Geoff P is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:59 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts