Go Back   Tech Support Forum > Microsoft Support > Windows XP Support

Add remove programs list is displaying weird results

This is a discussion on Add remove programs list is displaying weird results within the Windows XP Support forums, part of the Tech Support Forum category. Hello everyone. My ADD/Remove programs list is displaying odd results. I mean the program names in the currently installed programs


Closed Thread
 
Thread Tools Search this Thread
Old 03-30-2010, 09:38 AM   #1
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3


Confused

Hello everyone.

My ADD/Remove programs list is displaying odd results.
I mean the program names in the currently installed programs shows some weird names I havent seen before.The names are odd and many others that i know were there are not displaying anymore.
Please note Im pretty sure its not a malware/spyware thing.Im a pretty savvy Comp user and have scanned my comp using many good programs.
I know this happened because I used the "REVO UNINSTALLER" app to uninstall some unused programs during which i may have said yes to an option for deleting some system dll file that the deleted app was sharing.

So my question is does anyone know a series of steps i can take to fix my add/remove programs list?
Without resorting to system restore that is.
I have many enterprise apps on my system that took a lot of time to configure and I honestly dont trust system restore.It has screwed up some times.

Thanks
Tric

__________________
jacobtric is offline  
Old 03-30-2010, 09:53 AM   #2
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT



Welcome to TSF

There are many different solutions to fixing the Add/Remove Program applet. Are the Change, Remove (or Change/Remove) buttons missing? Are the Add-Remove Programs gone in the applet?

__________________
Geekgirl is offline  
Old 03-30-2010, 10:32 AM   #3
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



Hi GeekGirl

Thanks for the quick reply :-)
No the buttons are all there and the applet is loading a list of programs.
The problem is that many of the programs in the list have odd names.Names i haven't seen before and some other programs that i know should be there arn't showing up in the list.
I'm quite familiar with the list of currently installed programs as i use it to delete programs all the time.The list I'm seeing now is definitely weird.

Thanks
tric
__________________
jacobtric is offline  
Old 03-30-2010, 12:08 PM   #4
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT



Can you give us a screen shot plz?
__________________
Geekgirl is offline  
Old 03-30-2010, 02:07 PM   #5
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



Hi GeekGirl


Ive attached the screenshots.
The red rectangular blocks indicate suspect entries.

Thanks :-)

Tric
Attached Thumbnails
Click image for larger version

Name:	SShot1.JPG
Views:	30
Size:	51.9 KB
ID:	68480   Click image for larger version

Name:	SShot2.JPG
Views:	24
Size:	41.5 KB
ID:	68481  
__________________
jacobtric is offline  
Old 03-31-2010, 06:36 AM   #6
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT



Your missing the Change/Remove buttons.
Lets get the applet showing the correct info first then we will move on to the "weird" entries.

Click Start, Run and type REGEDIT. This starts the Registry Editor. Navigate to:

HKEY_LOCAL_MACHINE
\SOFTWARE
\Microsoft
\Windows
\CurrentVersion
\Uninstall
\<Program Name>

<Program Name> here is Adobe Acrobat 5.0 - Taken as an example

*

In the right-pane, do the following:

Double-click NoRemove (REG_DWORD) and set it to 0
Double-click NoModify (REG_DWORD) and set it to 0

If NoRemove is set to 1, the Remove button will be unavailable
If NoModify is set to 1, the Change button will be unavailable
__________________
Geekgirl is offline  
Old 03-31-2010, 07:11 AM   #7
TSF Team, Emeritus
 
Coolfreak's Avatar
 
Join Date: May 2008
Location: Wilkes-Barre, PA
Posts: 5,187
OS: Windows XP Pro / Windows Vista / Windows 7



Here's a KB that might help you. Make sure you follow Geekgirl's instructions first, though.

http://support.microsoft.com/kb/314481

On a side note - some google searches of the 'odd' entries seem to always point at something to do with HP. Is your computer an HP?
__________________
I subscribe to all threads I post in. But, if in case I don't or I forget, and I don't post back within 24 hours, please PM me. I will get back to your thread ASAP.
Coolfreak is offline  
Old 03-31-2010, 09:33 AM   #8
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



Hi GeekGirl and CoolFreak

Thanks for your replies.

Here's what I've found.
I have only 5 entries in the
HKEY_LOCAL_MACHINE
\SOFTWARE
\Microsoft
\Windows
\CurrentVersion
\Uninstall
directory.
None of them have the NoRemove NoModify set but each of them has a change remove button in the add/remove programs applet.

I looked for the other "weird entries" in the registry and have found as i suspected that they are from the original softwares that i have on my system but for some reason the Display name variable has these odd values and the keys are in the
HKEY_LOCAL_MACHINE
\SOFTWARE
\Microsoft
\Windows
\CurrentVersion
\Installer
\UserData
\S-1-5-18
\Products directory

for eg the weird entry "OGA Notifier 2.0.0048.0 is the Microsoft Genuine advantage that i have on my system.It showed the actual Display name before the add/remove got screwed up.

Im attaching some screens for you guys.
Please let me know if you figure something out or need more info..
Thanks
j
Attached Thumbnails
Click image for larger version

Name:	SShot3.JPG
Views:	18
Size:	95.7 KB
ID:	68524   Click image for larger version

Name:	SShot4.JPG
Views:	16
Size:	42.4 KB
ID:	68525  
__________________
jacobtric is offline  
Old 03-31-2010, 09:36 AM   #9
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



Hi

Just had one more attachement

:-)
Attached Thumbnails
Click image for larger version

Name:	SShot5.JPG
Views:	18
Size:	128.0 KB
ID:	68528  
__________________
jacobtric is offline  
Old 03-31-2010, 10:22 AM   #10
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



FYI

My computer is a DELL VOSTRO 1510
and the HP stuff is a printer driver i installed recently

J
__________________
jacobtric is offline  
Old 03-31-2010, 11:49 AM   #11
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT



Id like you to use this program plz


Download and install CleanUp! but do not run it yet.

*WARNING* Cleanup deletes EVERYTHING out of temp/temporary folders and does not make backups.

Open Cleanup! by double-clicking the icon on your desktop (or from the Start > All Programs menu). Set the program up as follows:
*Click "Options..."
*Move the arrow down to "Custom CleanUp!"
*Put a check next to the following:
  • Empty Recycle Bins
  • Delete Cookies
  • Delete Prefetch files
  • Cleanup! All Users
  • Click on the “Temporary Files” and uncheck the box for “Scan drives for file matching” if it’s checked.
Click OK
Press the CleanUp! button to start the program. Reboot/logoff when prompted.

Let me know how many files it removed
__________________
Geekgirl is offline  
Old 03-31-2010, 12:47 PM   #12
Registered Member
 
Join Date: Mar 2010
Posts: 7
OS: Win xp sp3



Hi GeekGirl


Ive attached a screenshot of the results after running Cleanup!

Will restart now.

Thanks
J
Attached Thumbnails
Click image for larger version

Name:	SShot6.JPG
Views:	23
Size:	40.8 KB
ID:	68543  
__________________
jacobtric is offline  
Old 03-31-2010, 01:01 PM   #13
TSF Team Emeritus
Microsoft Support
 
Geekgirl's Avatar
 
Join Date: Jan 2005
Location: Pennsylvania
Posts: 15,123
OS: XP Home SP3 x3 /XP Pro SP3/Vista Ultimate SP2/Win7 Pro 64-BIT



Not what I expected, thanks

__________________
Geekgirl is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:59 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts